felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <ben...@basistech.com>
Subject Re: Need help debugging Felix OSGi bundles (with Eclipse)
Date Sat, 12 Sep 2015 20:35:03 GMT
What goes wrong when you add:

-agentlib:jdwp=transport=dt_socket,server=y,suspend=y,address=5005

to the java command line and then attach from Eclipse?


On Sat, Sep 12, 2015 at 3:31 PM, Pedro Domingues
<pedro.domingues@ist.utl.pt> wrote:
> Hi,
>
> I really need to debug my code by the use of breakpoints, however this seems
> a complex undertaking with an OSGi container.
>
> I have Eclipse and Felix (both the latest). My project is a raw OSGi
> project, I am not using PDE, just maven bundle plugin to generate the
> bundles and then copy them to the /bundle folder in felix, then I perform
> java -jar bin/felix.jar and the project runs. So no fuss here.
>
> However I cannot debug the application that way. I've tried to read the docs
> (http://felix.apache.org/documentation/development/integrating-felix-with-eclipse.html)
> but they are outdated/broken and cant make them work...
>
> How can I debug this? Will I have to avoid using OSGi just because debug is
> not supported...? :(
>
> Thanks!
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
> For additional commands, e-mail: users-help@felix.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message