felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schneider <ch...@die-schneider.net>
Subject Uses constraint violation when installing activemq-blueprint feature in karaf 4 (uses felix resolver)
Date Fri, 29 May 2015 08:09:34 GMT
We often see a uses constraint violation when installing the 
activemq-blueprint feature in apache karaf 4.0.0-SNAPSHOT.
I am writing to the felix user group as karaf 4 uses the felix resolver 
1.2.0 and the exception is thrown by this code.

See the full issue here:
https://issues.apache.org/jira/browse/KARAF-3748

I wonder why there is an exception at all as the two chains end in the 
same bundle org.apache.aries.blueprint.core/1.4.3 . I would have 
expected this to be a normal situation. So the first thing I would like 
to understand is if this is an issue with the activemq bundles or rather 
with the resolver itself.

Christian

-- 
Christian Schneider
http://www.liquid-reality.de

Open Source Architect
http://www.talend.com


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message