felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neil Bartlett <njbartl...@gmail.com>
Subject Re: Why would a bundle not start?
Date Fri, 09 Jan 2015 15:22:25 GMT
Yes exactly. OSGi never automatically starts bundles.

Start level n merely means that the bundle cannot start until the framework reaches that level,
even if the Bundle.start method is invoked.  

-- 
Neil Bartlett
Sent from a phone


On Friday, 9 January 2015 at 15:08, Benson Margulies wrote:

> I have a container that I've installed some bundles into.
> 
> One of them has an activator. If I enumerate the bundles, I see this
> bundle, I see that it has a persistent start level of 1. I start up Felix,
> with the framework start level set to 1. My bundle's activator is not
> called.
> 
> Do I in fact have to iterate my bundles calling 'start' even if they have
> persistent start levels?
> 
> 
> 
> Bnd-LastModified 1420814804179
> Build-Jdk 1.7.0_72
> Built-By Basis Technology Corp.
> Bundle-Activator com.basistech.rosette.osgi.impl.BusActivator
> Bundle-Description Define the api to a component.
> Bundle-DocURL http://basistech.com
> Bundle-ManifestVersion 2
> Bundle-Name rosette-osgi-api
> Bundle-SymbolicName com.basistech.osgi.rosette-osgi-api
> Bundle-Vendor Basis Technology Corp.
> Bundle-Version 0.0.4.SNAPSHOT
> Created-By Apache Maven Bundle Plugin
> Export-Package
> com.basistech.rosette.osgi;version="0.0.4";uses:="com.basistech.rosette,
> com.basistech.rosette.dm,org.osgi.framework"
> Implementation-Title rosette-osgi-api
> Implementation-Vendor Basis Technology Corp.
> Implementation-Vendor-Id com.basistech.osgi
> Implementation-Version 0.0.4-SNAPSHOT
> Import-Package com.basistech.rosette,com.basistech.rosette.dm
> ;version="[1.10,2)",com.basistech.rosette.osgi;version="[0.0,1)",com.fasterxml.jackson.core;version="[2.4,3)",com.fasterxml.jackson.core.type;version="[2.4,3)",com.fasterxml.jackson.databind;version="[2.4,3)",com.fasterxml.jackson.databind.node;version="[2.4,3)",com.fasterxml.jackson.dataformat.yaml;version="[2.4,3)",com.google.common.base;version="[16.0,17)",com.google.common.collect;version="[16.0,17)",
> com.google.common.io
> ;version="[16.0,17)",org.osgi.framework;version="[1.7,2)",org.slf4j;version="[1.7,2)"
> Manifest-Version 1.0
> Require-Capability osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.6))"
> Tool Bnd-2.4.0.201411031534
> Start level: 1
> 
> 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message