felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <ben...@basistech.com>
Subject Re: org.osgi.framework version range chosen by plugin
Date Tue, 18 Nov 2014 11:17:18 GMT
On Tue, Nov 18, 2014 at 3:59 AM, Neil Bartlett <njbartlett@gmail.com> wrote:
> You probably shouldn’t change this. The version range is wide, which allows people
to use your bundle if they are running an older framework. It does not prevent you from using
a higher version if you wish.

I confess: I'd made dumb error in my launcher of setting system
packages instead of extra system packages (by leakage from pax-exam) ,
and caused the framework package not to wire, and so I got mistakenly
concerned about the version. It's all working now.

>
> You should only change the import to use a higher version (e.g. 1.5) if your bundle *cannot*
work with version 1.4 of the package. You do this by explicitly compiling against the lowest
version of the library your bundle can work with.
>
> Neil
>
>> On 18 Nov 2014, at 02:04, Benson Margulies <benson@basistech.com> wrote:
>>
>> the maven-bundle-plugin decided to put the following into the
>> manifest, even though I'm using a much newer version of OSGi. Should I
>> just add an instruction to set a version I like better, or is there
>> something more subtle I've missed that would clue it in?
>>
>> org.osgi.framework;version="[1.4,2)"
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
>> For additional commands, e-mail: users-help@felix.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
> For additional commands, e-mail: users-help@felix.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message