felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <ben...@basistech.com>
Subject Re: maven-bundle-plugin: Imports without versions, why?
Date Wed, 26 Nov 2014 14:33:34 GMT
On Wed, Nov 26, 2014 at 9:25 AM, Felix Meschberger <fmeschbe@adobe.com> wrote:
> Hi Benson
>
> Do you have two dependencies in the class path which contain the same com.basistech.rosette
package ?

I hope not. I don't get any split-package warnings after I went to a
good deal of trouble fix that up. I'll go hunting.

>
> Regards
> Felix
>
> Am 26.11.2014 um 14:56 schrieb Benson Margulies <benson@basistech.com>:
>>
>>
>> I don't know if this is, in fact, a bnd question. Here's an import
>> generated by the plugin. Note that there's a version on the first, and
>> not on the second.
>>
>> Import-Package: com.basistech.rosette,com.basistech.rosette.dm;version="
>> [1.10,2)"
>>
>> Here is the Export-Package in the manifest of the bundle that exports
>> com.basistech.rosette:
>>
>> Export-Package: com.basistech.rosette;version="34.0.0",com.basistech.ros
>> ette.util;version="34.0.0",com.basistech.util;version="34.0.0"
>>
>> Note the version.
>>
>> So, howcome I don't get a version on the import?
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
>> For additional commands, e-mail: users-help@felix.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
> For additional commands, e-mail: users-help@felix.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message