felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raymond Auge <raymond.a...@liferay.com>
Subject Re: Export-Package with {local-packages} yields version mix
Date Sun, 12 Oct 2014 14:16:28 GMT
On Sun, Oct 12, 2014 at 9:25 AM, rsteppac2 <ralf@steppacher.name> wrote:

> Neil,
>
> thanks for pointing out the missing closing quote. However, it does not
> change the results.
>
> As for the API, a snapshot version like 3.0.0-SNAPSHOT might actually
> differ
> in its API from the final version 3.0.0.


OSGi expects that semantically these are API equivalent! If you are not
honouring semantic versioning then you really ARE forcing it upon yourself
and your users to have effectively static dependencies between bundles
which is very bad design from OSGi's point of view.

.. unless I'm really not understanding what that sentence means.

- Ray



> But of course, it is a special case
> and for all versions above 3.0.0 I would think your reply  here
> <
> http://apache-felix.18485.x6.nabble.com/Why-import-version-range-if-exact-version-of-dependency-is-known-tp5010123.html
> >
> applies.
>
>
> Thanks!
> Ralf
>
>
>
> --
> View this message in context:
> http://apache-felix.18485.x6.nabble.com/Export-Package-with-local-packages-yields-version-mix-tp5010124p5010130.html
> Sent from the Apache Felix - Users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
> For additional commands, e-mail: users-help@felix.apache.org
>
>


-- 
*Raymond Augé* <http://www.liferay.com/web/raymond.auge/profile>
 (@rotty3000)
Senior Software Architect
*Liferay, Inc.* <http://www.liferay.com> (@Liferay)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message