felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dawid Loubser <da...@travellinck.com>
Subject Re: Apache Bundle deploy issue
Date Thu, 18 Sep 2014 14:08:37 GMT
Generally-speaking, it sounds like you are using a class inside the
bundle that is not being declared as a dependency in the OSGi metadata
(e.g. "Import-package" of your bundle). Another option is that you added
a class to a bundle that you're using, but you didn't upgrade the
version of that bundle.

Could you provide a little bit more detail perhaps?

kind regards,
Dawid


On 18/09/2014 15:28, Karoly Tanczos wrote:
>
> Hi,
>
>  
>
> My name is Karoly Tanczos and I’m in a middle of a migration project
> and I need some help.
>
>  
>
> I deployed a bundle update on our Adobe CQ WCM 5.4 environment. The
> bundle is active, I can’t see any issue on Bundle Console but our CQ
> page preview is failing with the following error:
> java.lang.NoClassDefFoundError.
>
>  
>
> Could you please help me with some advice what can be the issue? Is
> there other way to deploy bundles then through Apache Felix Bundle
> Console? If not do we need to stop the CQ before the deploy or do we
> need to restart CQ after the restart?
>
>  
>
> Thanks,
>
> Karesz
>
>  
>
> *Károly Tánczos *- *Global Brands Web Ops and Release - Marketing IT**
> *Austin IT Innovation Center; 717 East Parmer Lane, Austin , TX 78753
> 512-239-9076 C
>
> Logos
>
>  
>
>
>
> Nothing in this message is intended to constitute an electronic
> signature unless a specific statement to the contrary is included in
> this message.
>
> Confidentiality Note: This message is intended only for the person or
> entity to which it is addressed. It may contain confidential and/or
> privileged material. Any review, transmission, dissemination or other
> use, or taking of any action in reliance upon this message by persons
> or entities other than the intended recipient is prohibited and may be
> unlawful. If you received this message in error, please contact the
> sender and delete it from your computer. 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message