felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CLEMENT Jean-Philippe <jean-philippe.clem...@fr.thalesgroup.com>
Subject RE: OSGi and JDK8 Status?
Date Fri, 24 Jan 2014 09:09:11 GMT
I wrote to quick and sent an erratum: " It's not the syntax the Eclipse Maven plugin fails
on but it uses Java4 instead and needs manual modification on the project to set Java8 (any
"update" command on the project will go back to Java4)."

To be clear at present time I succeed in using Java8 from Eclipse to Karaf. However, for bundles
code I do not use the new Java8 syntax capabilities and stick with Java7 ones. I need Java8
mainly for its enhanced JavaFX lib. When I do POCs I use Lambdas which are often useful.

JP

[@@ THALES GROUP INTERNAL @@]


-----Message d'origine-----
De : Mark Derricutt [mailto:mark@talios.com] 
Envoyé : vendredi 24 janvier 2014 00:25
À : users@felix.apache.org
Objet : Re: OSGi and JDK8 Status?

On 23 Jan 2014, at 21:39, CLEMENT Jean-Philippe wrote:

> I don't have any trouble with the Maven scr plugin, but the Eclipse 
> plugin does not support new Java8 syntax. Neither Checkstyle.

Interesting - thats the main one I'm having issues with actually.  
scr-annotations for the components/services or some other BND annotations?

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message