felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roland <...@ids.de>
Subject Re: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=
Date Mon, 26 Aug 2013 08:27:43 GMT
Hi
GoldeneyeModellingFramework has a package-dependency on
com.host.domain.sharedpersonalize.storageservice (Version 1.xxx) which can
not be resolved. You have to import that bundle which exports this package
and/or you have to add permissions if you use java-2-security.

something like this...
  <dependency>
    <groupId>com.host.domain</groupId>
    <artifactId>sharedpersonalize</artifactId>
    <version>1.x.x.x</version>
    <scope>provided</scope> 
  </dependency>

(org.osgi.framework.PackagePermission
"com.host.domain.sharedpersonalize.storageservice" "import")

take a look on the error msg.
"GoldeneyeModellingFramework [1]: Unable to resolve 1.0: missing requirement
[1.0] osgi.wiring.package;
(&(osgi.wiring.package=com.host.domain.sharedpersonalize.storageservice)(version>=1.0.0)(!(version>=2.0.0)))"

"osgi.wiring.package" is the category of dependency and
"com.host.domain.sharedpersonalize.storageservice" is the package.

regards



--
View this message in context: http://apache-felix.18485.x6.nabble.com/Unable-to-resolve-1-0-missing-requirement-1-0-osgi-wiring-package-osgi-wiring-package-tp5004697p5004708.html
Sent from the Apache Felix - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message