felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: DS - activate method [activate] not found; Component will fail
Date Sat, 20 Jul 2013 22:20:55 GMT
Is the signature of the activate method consistent with the xml namespace of the ds descriptor?
 The annotations get converted to xml and the SCR runtime doesn't look at the annotations
so the first step is to figure out whether the xml is consistent with the signature.  I'm
pretty sure bnd gets the namespace right but not so sure about the felix scr plugin.  Showing
us the activate method signature and the xml descriptor would be useful.

thanks
david jencks

On Jul 20, 2013, at 11:53 AM, bokie <jms.cercas@gmail.com> wrote:

> Hi gang,
> 
> I'm getting a strange output in my logs with respect to one specific bundle
> in my project.
> 
> The SCR generates an output saying: *activate method [activate] not found;
> Component will fail*
> 
> I don't see anything wrong with the implementation - I've declared AND
> annotated an activate, deactivate and modified method.
> 
> Any ideas?
> 
> Thanks
> Jorge
> 
> 
> 
> 
> --
> View this message in context: http://apache-felix.18485.x6.nabble.com/DS-activate-method-activate-not-found-Component-will-fail-tp5004353.html
> Sent from the Apache Felix - Users mailing list archive at Nabble.com.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
> For additional commands, e-mail: users-help@felix.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message