felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart McCulloch <mccu...@gmail.com>
Subject Re: maven-bundle-plugin fails when dependencies compiled with Java 1.7 is used!
Date Wed, 17 Jul 2013 17:08:55 GMT
Which version are you using?  Version 2.4.0 is known to work with Java7 bytecode.

Also the maven-bundle-plugin doesn't get involved in the actual compiling, so it sounds like
something else is likely going on which may (or may not) be related to the empty bundle.

Perhaps you could reduce it down to a small test project to demonstrate the problem.

On 17 Jul 2013, at 16:36, Tommy Svensson wrote:

> Hello,
> 
> My name is Tommy Svensson and I'm new to this list. I just signed up. 
> 
> I've been using the maven-bundle-plugin for quite a while and really like it. I just
however had the strangest problem: I added a dependency to my pom and suddenly I got an empty
jar! It compiles without an error, but no classes are put in the jar. I wondered if it at
all compiled my code so I made some errors in it that should not compile and then did clean
and install. Still it built without errors, and no classes were produced. This indicates that
it is not even compiling anything. 
> 
> To skip a very long trouble shooting lets start at what I found to be the problem: The
added dependency was a jar from another of my own projects. It was compiled with java 1.7.
I backed the code in that project to 1.6 and rebuilt with 1.6. Now everything is behaving
as it should again, and I get my code compiled and I get classes in the jar in the project
using maven-bundle-plugin. That project is also using 1.7, but that seems to be OK. Dependencies
can however not be compiled with any java version greater than 1.6 it seams! Note that I'm
building with a 1.7 JDK!
> 
> Have anyone else experienced this problem ? Has anyone succeeded in using 1.7 compiled
dependencies with m-b-p ? Is this a known problem with a workaround ?
> 
> Best Regards,
> Tommy Svensson
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
> For additional commands, e-mail: users-help@felix.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message