felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pigelvy <pigelvy....@gmail.com>
Subject Re: Leap Motion in OSGi : EXCEPTION_VIOLATION_EXCEPTION
Date Mon, 29 Jul 2013 13:59:45 GMT
For the basic need of having Leap Motion work in OSGi, I managed to do it as
explained in  my StackOverflow post
<http://stackoverflow.com/questions/17858647/exception-access-violation-when-accessing-leapmotion-api-within-osgi/17924911#17924911>

.

Basically, I create an hello-world bundle with simple Leap Motion
interaction. I only had to pre-load the Lead.dll library.

After that, I tried to apply the exact same principles to my real project
bundle, but I end up with native code exceptions such as:

   # A fatal error has been detected by the Java Runtime Environment: 
   # 
   #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00000000, pid=7492,
tid=5696 
   # 
   # JRE version: 6.0_30-b12 
   # Java VM: Java HotSpot(TM) Client VM (20.5-b03 mixed mode windows-x86 ) 
   # Problematic frame: 
   # C  0x00000000 


You probably don't know the Leap Motion SDK but I do receive several Leap
events before the JVM crashes with a "problematic frame".

My real bundle does not contain native code. I just don't understand why the
leap SDK fails to operate within my bundle. Even though you never worked
with LeapMotion, have you ever experienced something similar?

thx



--
View this message in context: http://apache-felix.18485.x6.nabble.com/Leap-Motion-in-OSGi-EXCEPTION-VIOLATION-EXCEPTION-tp5004404p5004426.html
Sent from the Apache Felix - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message