felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neil Bartlett <njbartl...@gmail.com>
Subject Re: installBundle() IllegalArgumentException
Date Tue, 25 Jun 2013 10:50:19 GMT
It looks like an invalid entry in the manifest of the bundle you're
trying to install.

Neil

On Tue, Jun 25, 2013 at 11:44 AM, Roland <wgl@ids.de> wrote:
> Hi all!
> during unit-tests I get a exception in this line of code
> bundle = bundlecontext.installBundle(URL);
>
> *What does "No path specified on clause" mean?*
>
> ERROR: Bundle org.apache.felix.framework [0] EventDispatcher: Error during
> dispatch. (java.lang.IllegalArgumentException: No path specified on clause:
> org.osgi.service.log:version=1.3)java.lang.IllegalArgumentException: No path
> specified on clause: org.osgi.service.log:version=1.3
>         at org.apache.felix.utils.manifest.Parser.parseClauses(Parser.java:75)
>         at org.apache.felix.utils.manifest.Parser.parseHeader(Parser.java:40)
>         at
> org.apache.felix.bundlerepository.impl.DataModelHelperImpl.doImports(DataModelHelperImpl.java:733)
>         at
> org.apache.felix.bundlerepository.impl.DataModelHelperImpl.populate(DataModelHelperImpl.java:556)
>         at
> org.apache.felix.bundlerepository.impl.LocalResourceImpl.initialize(LocalResourceImpl.java:56)
>         at
> org.apache.felix.bundlerepository.impl.LocalResourceImpl.<init>(LocalResourceImpl.java:39)
>         at
> org.apache.felix.bundlerepository.impl.LocalRepositoryImpl.addBundle(LocalRepositoryImpl.java:98)
>         at
> org.apache.felix.bundlerepository.impl.LocalRepositoryImpl.bundleChanged(LocalRepositoryImpl.java:54)
>         at
> org.apache.felix.framework.util.EventDispatcher.invokeBundleListenerCallback(EventDispatcher.java:868)
>         at
> org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:789)
>         at
> org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:514)
>         at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4408)
>         at org.apache.felix.framework.Felix.installBundle(Felix.java:3048)
>         at
> org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165)
>         at
> org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:138)
>
>
>
> --
> View this message in context: http://apache-felix.18485.x6.nabble.com/installBundle-IllegalArgumentException-tp5004110.html
> Sent from the Apache Felix - Users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
> For additional commands, e-mail: users-help@felix.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message