felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferry Huberts <maili...@hupie.com>
Subject Re: Invalid package name: '*' ????
Date Fri, 21 Jun 2013 13:44:28 GMT


On 21/06/13 15:28, Roland wrote:
> hello,
> I'm at it again .... and I hope I'm right here.
> 
> I hang on a problem for a few hours. I do not know what I'm doing wrong.
> Below is the error message and my POM. 
> 
> ...
> [INFO] [bundle:bundle {execution: default-bundle}]
> in default pack? 
> [WARNING] Bundle mygroupId:myartifactId:bundle:1.0.0.0 : Invalid package
> name: '*'
> [ERROR] Bundle
> de.ids.acos.rtu.osgi.bundles:acos-rtu-constants:bundle:1.0.0.0 : The default
> package '.' is not permitted by the Import-Package syntax. 
>  This can be caused by compile errors in Eclipse because Eclipse creates 
> valid class files regardless of compile errors.
> The following package(s) import from the default package null
> [ERROR] Error(s) found in bundle configuration
> 
> 
> 
> <project xmlns="http://maven.apache.org/POM/4.0.0"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
>   <modelVersion>4.0.0</modelVersion>
>   <parent>
>     <groupId>mygroupID</groupId>
>     <artifactId>myparent</artifactId>
>     <version>1.0.0.0</version>
>   </parent>
>   <groupId>mygroupID</groupId>
>   <artifactId>myproject</artifactId>
>   <name>myproject</name>
>   <packaging>bundle</packaging>
>   <build>
>     <plugins>
>       <plugin>
>         <groupId>org.apache.felix</groupId>
>         <artifactId>maven-bundle-plugin</artifactId>
>         <extensions>true</extensions>
>         <configuration>
>           <archive>
>           </archive>
>           <instructions>
>            
> <Bundle-SymbolicName>${project.groupId}.${project.artifactId}</Bundle-SymbolicName>
>             <Bundle-Description>${project.description}</Bundle-Description>
>             <Bundle-Version>${project.version}</Bundle-Version>
>             <Bundle-Activator></Bundle-Activator>
>             <EXPORT-PACKAGE>
>               mypackage;version=1.0.0.0
>             </EXPORT-PACKAGE>
>             <IMPORT-PACKAGE>
>               *
>             </IMPORT-PACKAGE>


I'm not a maven user, but try without the import-package section.
bnd calculates this for you.

>           </instructions>
>         </configuration>
>       </plugin>
>     </plugins>
>   </build>
> </project>
> 
> 
> 
> I have already tried "mvn clean", but that does not help. Recently I get
> frequently strange error messages from maven. From time to time I can not
> build my projects and I get the following error message: ... Source not
> found. This indicates that the compiler can not find the source. After a
> further try everything works again! There is probably a bug somewhere in the
> Maven-Universe. Maybe I should ask this in a Maven forum.
> 
> Any suggestions?
> 
> Thanks in advance!
> Roland
> 
> 
> 
> --
> View this message in context: http://apache-felix.18485.x6.nabble.com/Invalid-package-name-tp5004065.html
> Sent from the Apache Felix - Users mailing list archive at Nabble.com.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
> For additional commands, e-mail: users-help@felix.apache.org
> 

-- 
Ferry Huberts

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message