felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roland <...@ids.de>
Subject Loader constraint violation. gogo-command exports org.osgi.service.log
Date Thu, 20 Jun 2013 14:01:54 GMT
Hi everyone,

today I ran into the issue "loader constraint violation". I figured out that
this is caused by gogo-command which exports the package
org.osgi.service.log that is also exported by org.osgi.compendium. How can I
prevent my own bundle to import org.osgi.service.log from
org.apache.felix.gogo.command? Why gogo-command exports this package?

by the way...
I also have a problem with gogo-command in my auto-generated OBR-file (by
maven-obr-plugin).
This line throws an java.lang.Exception:
<require extend="false"
filter="(&amp;(package=org.apache.felix.service.command)(version&gt;=0.10.0)(version&lt;1.0.0)(status=provisional)(mandatory:&lt;*status))"
multiple="false" name="package" optional="false">Import package
org.apache.felix.service.command ;version=[0.10.0,1.0.0)</require>
I don't no why...

Many thanks in advance!
Roalnd




--
View this message in context: http://apache-felix.18485.x6.nabble.com/Loader-constraint-violation-gogo-command-exports-org-osgi-service-log-tp5004055.html
Sent from the Apache Felix - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message