felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roland <...@ids.de>
Subject Compatibility problem between osgi 4.3 & felix bundle repository 1.6.6
Date Mon, 03 Jun 2013 13:00:12 GMT
Hello community,
After I integrated the Felix-Bundle-Repository
(org.apache.felix.bundlerepository 1.6.6) some OSGi 4.3 methods could not be
resolved such as Bundle.adapt () or Bundle.getVersion (). The reason is that
Felix-Bundle-Repository requires OSGi-Core-4.1.0.
As short-term solution I deleted the OSGi Core 4.1 dependency from the build
path. However, that is reversed if i run  eclipse:eclipse . Does anyone have
a better idea?

Thank you very much
Roland



--
View this message in context: http://apache-felix.18485.x6.nabble.com/Compatibility-problem-between-osgi-4-3-felix-bundle-repository-1-6-6-tp5003637.html
Sent from the Apache Felix - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message