felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Søren Dalby Larsen <sdlar...@gmail.com>
Subject Re: Problems resolving simple iPojo component
Date Tue, 21 May 2013 09:15:38 GMT
Hi Richard,

Thank you for the reply. I messed up in the syntax of exported packages
from the embedded felix. It's all good now.

/Søren


On Fri, May 10, 2013 at 4:11 PM, Richard S. Hall <heavy@ungoverned.org>wrote:

> The first question to answer is whether or not you also installed a bundle
> that exports package dk.atira.pure.api.shared.**services?
>
> And what's up with that bundle #5? It looks like you installed a source
> JAR as a bundle...
>
> -> richard
>
>
> On 5/10/13 07:38 , Søren Dalby Larsen wrote:
>
>> Hi all,
>>
>> Noob alert! This is my first with iPojo.
>>
>> I've embedded Felix into a large legacy webapp and installed iPojo.
>>
>> Without my simple client i can attach to my application using nc and list
>> the bundles:
>>
>>
>> Welcome to Apache Felix Gogo
>>
>> g! lb
>> START LEVEL 1
>> ID|State |Level|Name
>> 0|Active | 0|System Bundle (4.2.1)
>> 1|Active | 1|Apache Felix Gogo Command (0.12.0)
>> 2|Active | 1|Apache Felix Gogo Runtime (0.10.0)
>> 3|Active | 1|Apache Felix Gogo Shell (0.10.0)
>> 4|Active | 1|Apache Felix iPOJO (1.8.6)
>> 5|Active |
>> 1|jar:file:/home/sdl/.m2/**repository/dk/atira/pure/**
>> modules/osgi/osgi-core-**bundled/4.17.0-SNAPSHOT/osgi-**
>> core-bundled-4.17.0-SNAPSHOT.**jar!/standardbundles/org.**
>> apache.felix.ipojo.**annotations-1.8.6-sources.jar
>> (0.0.0)
>> 6|Active | 1|Apache Felix iPOJO Annotations (1.8.6)
>> 7|Active | 1|Apache Felix iPOJO Arch Command (1.6.0)
>> 8|Active | 1|Apache Felix iPOJO Gogo Command (1.0.1)
>> 9|Active | 1|Apache Felix Shell Service (1.4.3)
>> 10|Active | 1|Apache Felix Remote Shell (1.1.2)
>> 11|Active | 1|Apache Felix Shell TUI (1.4.1)
>>
>> That seems fine - all active. Now when installing my iPojo component i
>> get:
>>
>> 17|Installed | 1|pure-osgi-test OSGi Bundle (1.0.0.SNAPSHOT)
>>
>> and when trying to start it:
>>
>> org.osgi.framework.**BundleException: Unresolved constraint in bundle
>> pure-osgi-test [17]: Unable to resolve 17.0: missing requirement [17.0]
>> osgi.wiring.package; (osgi.wiring.package=dk.atira.**
>> pure.api.shared.services)
>>
>> as if osgi packages are not available. I've used the maven tutorial as an
>> example, except for the interface being exported from the legacy webapp,
>> and no functionality is in my iPojo bean exept for start and stop methods.
>>
>> Obviously I miss something basic. Any suggestions?
>>
>> /Søren
>>
>>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: users-unsubscribe@felix.**apache.org<users-unsubscribe@felix.apache.org>
> For additional commands, e-mail: users-help@felix.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message