felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tribon Cheng <tribon1...@gmail.com>
Subject Re: Creating OSGI bundles to provide dependency resolution in eclipse p2 repositories
Date Thu, 04 Apr 2013 11:52:42 GMT
Exactly, Eclipse does not support building against bundles containing
nested JARs.


On Wed, Apr 3, 2013 at 4:16 PM, Robert Gruendler <r.gruendler@gmail.com>wrote:

> On Apr 2, 2013, at 3:11 PM, Ferry Huberts <mailings@hupie.com> wrote:
> > 1- put the generated 'wrap' bundle in a repository and use it from there
>
> for anyone interested: The workaround mentioned above works fine with
> eclipse. So basically you have 2
> build steps:
>
> 1.maven-bundle build which generates the bundle artefacts
> 2. tycho build which generates a p2 repository containing the bundles
>
> I wasn't able to put these 2 steps together in a single project, i think
> it's because you can't mix pom-first builds
> with tycho's manifest-first. Anyway, that way it works just fine.
>
>
> Thanks for your help!
>
>
> regards
>
> -robert
>
>
>
> [1] https://github.com/pulse00/osgi-bundles
> [2] https://github.com/pulse00/osgi-repository




-- 
Contribute to Enterprise Integration

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message