felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferry Huberts <maili...@hupie.com>
Subject Re: Creating OSGI bundles to provide dependency resolution in eclipse p2 repositories
Date Tue, 02 Apr 2013 13:11:12 GMT


On 02/04/13 14:56, Robert Gr√ľndler wrote:
> isn't maven-bundle-plugin just a maven plugin wrapping bnd?
> 


yes it is.

We have a similar issue with bndtools:
When we create a wrap project, we can build the bundle just fine. but we
can't convince Eclipse to import from that bundle.

We're thinking on how to work around/fix this but we haven't found a
solution so far.

The workaround for us so far has been 1 of these 2 solutions:
1- put the generated 'wrap' bundle in a repository and use it from there
2- extract the sources from the 'wrap' bundle and put them in the src
folder of the project

> 
> -robert
> 
> 
> 
> 
> On Tue, Apr 2, 2013 at 2:52 PM, Tribon Cheng <tribon1980@gmail.com> wrote:
> 
>> why not to use bnd?
>>
>> On Tue, Apr 2, 2013 at 8:37 PM, Robert Gruendler <r.gruendler@gmail.com
>>> wrote:
>>
>>> Hi all,
>>>
>>> I'm working on a couple of eclipse plugins which have dependencies to 3rd
>>> party libraries. Some of those libraries
>>> are not available as OSGI bundles, so i need to wrap them in OSGI bundles
>>> manually.
>>>
>>> I've created a maven project [1] which uses the maven-bundle-plugin to
>>> embed the maven dependencies in the generated
>>> bundle.
>>>
>>> This works fine when building the project in the commandline, but in
>>> eclipse i'm experiencing this odd behavior:
>>>
>>> 1. The bundle can be resolved properly
>>> 2. When importing classes from the 3rd party library embedded in the
>>> bundle, i'm gettting the following Error in eclipse:
>>>
>>> "Cannot find the class file for org.json.simple.parser.ParseException"
>>> where ParseException is a class from the 3rd party dependency
>>> which should be embedded in the bundle generated by the
>>> maven-bundle-plugin.
>>>
>>>
>>> Am i having just a misconfiguration here with my pom, or am i going down
>>> the wrong track to tackle this bundle?
>>>
>>>
>>> regards
>>>
>>>
>>> -robert
>>>
>>>
>>> [1]
>>>
>> https://github.com/pulse00/osgi-repository/blob/master/simple-json/pom.xml
>>>
>>>
>>>
>>
>>
>> --
>> Contribute to Enterprise Integration
>>
> 
> 
> 

-- 
Ferry Huberts

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message