felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reto Bachmann-Gmür <r...@wymiwyg.com>
Subject Re: felix security: Bundle in cache doesn't pass security check anymore.
Date Tue, 12 Feb 2013 07:06:44 GMT
Hi Karl

Trying to compile the trunk version of framework.security I get:

[INFO] --- maven-compiler-plugin:2.3.2:compile (default-compile) @
org.apache.felix.framework.security ---
[INFO] Compiling 11 source files to
/data-ssd-unencrypted/projects-apache/felix/framework.security/target/classes
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /data-ssd-unencrypted/projects-apache/felix/framework.security/src/main/java/org/apache/felix/framework/security/condpermadmin/ConditionalPermissionAdminImpl.java:[310,19]
error: FakeBundle is not abstract and does not override abstract
method adapt(Class) in Bundle
[ERROR] /data-ssd-unencrypted/projects-apache/felix/framework.security/src/main/java/org/apache/felix/framework/security/condpermadmin/ConditionalPermissionAdminImpl.java:[464,15]
error: name clash: <A>adapt(Class<A>) in FakeBundle and adapt(Class)
in Bundle have the same erasure, yet neither overrides the other
[INFO] 2 errors

Cheers,
Reto

On Mon, Feb 11, 2013 at 11:19 PM, Karl Pauls <karlpauls@gmail.com> wrote:
> You could try to see whether it works with the current framework.security
> trunk. If not, please open a jira (and if possible attach some example that
> fails :-)
>
> regards,
>
> Karl
>
>
> On Mon, Feb 11, 2013 at 10:49 PM, Karl Pauls <karlpauls@gmail.com> wrote:
>
>> Looks like a bug to me. Can you please open a jira issue and assign it to
>> me?
>>
>> regards,
>>
>> Karl
>>
>>
>> On Mon, Feb 11, 2013 at 10:01 PM, Reto Bachmann-Gmür <reto@apache.org>wrote:
>>
>>> Hello,
>>>
>>> After updating clerezza to the latest released versions of felix and
>>> felix security I'm getting the following error after a restart:
>>>
>>> ERROR: Bundle in cache doesn't pass security check anymore.
>>> (java.lang.ArrayIndexOutOfBoundsException: -1)
>>> java.lang.ArrayIndexOutOfBoundsException: -1
>>>         at
>>> org.apache.felix.framework.security.verifier.BundleDNParser.getRootChains(BundleDNParser.java:470)
>>>         at
>>> org.apache.felix.framework.security.verifier.BundleDNParser._getDNChains(BundleDNParser.java:246)
>>>         at
>>> org.apache.felix.framework.security.verifier.BundleDNParser.checkDNChains(BundleDNParser.java:145)
>>>         at
>>> org.apache.felix.framework.SecurityProviderImpl.checkBundle(SecurityProviderImpl.java:63)
>>>         at
>>> org.apache.felix.framework.Felix.setBundleProtectionDomain(Felix.java:854)
>>>         at org.apache.felix.framework.Felix.init(Felix.java:805)
>>>         at org.apache.felix.framework.Felix.start(Felix.java:882)
>>>         at
>>> org.apache.clerezza.platform.launcher.ClerezzaApp.start(ClerezzaApp.java:184)
>>>         at
>>> org.apache.clerezza.platform.launcher.ClerezzaApp.start(ClerezzaApp.java:167)
>>>         at org.apache.clerezza.platform.launcher.Main.main(Main.java:34)
>>>
>>> Any idea what might cause this?
>>>
>>> Cheers,
>>> Reto
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
>>> For additional commands, e-mail: users-help@felix.apache.org
>>>
>>>
>>
>>
>> --
>> Karl Pauls
>> karlpauls@gmail.com
>> http://twitter.com/karlpauls
>> http://www.linkedin.com/in/karlpauls
>> https://profiles.google.com/karlpauls
>>
>
>
>
> --
> Karl Pauls
> karlpauls@gmail.com
> http://twitter.com/karlpauls
> http://www.linkedin.com/in/karlpauls
> https://profiles.google.com/karlpauls

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message