felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lessonz <lessonz.leg...@gmail.com>
Subject Re: Problem with 3rd Party Bundle
Date Tue, 09 Oct 2012 02:47:04 GMT
Okay, so it does look like there may be a binary incompatibility. I was
worried about just switching out dependencies like that. So, I guess I'm
back to my original question, how do I need to configure the
maven-bundle-plugin to resolve the issue?

Thanks:

I'm trying to use:

            <dependency>
                <groupId>org.restlet.android</
groupId>
                <artifactId>org.restlet.ext.json</artifactId>
                <version>2.0.15</version>
            </dependency>

which in turn depends upon:

        <dependency>
            <groupId>org.restlet.android</groupId>
            <artifactId>org.restlet.lib.org.json</artifactId>
            <version>2.0.15</version>
        </dependency>

The first is a bundle. The second is not. When I try to start my app, I get:

ERROR: Bundle org.restlet.ext.json [14] Error starting
[...]\org.restlet.ext.json-2.0.15.jar
 (org.osgi.framework.BundleException: Unresolved constraint in bundleorg.restle
t.ext.json [14]: Unable to resolve 14.0: missing requirement [14.0]
osgi.wiring.
package; (osgi.wiring.package=org.json))
org.osgi.framework.BundleException: Unresolved constraint in bundleorg.restlet.
ext.json [14]: Unable to resolve 14.0: missing requirement [14.0]
osgi.wiring.pa
ckage; (osgi.wiring.package=org.json)[FelixDispatchQueue] DEBUG
org.apache.felix
.ipojo - BundleEvent STARTED

[FelixDispatchQueue] DEBUG org.apache.servicemix.bundles.commons-codec -
BundleE
vent STARTED
        at
org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382
6)[FelixDispatchQueue] DEBUG org.restlet - BundleEvent STARTED

        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
[FelixDispatchQueue] DEBUG org.restlet.ext.json - FrameworkEvent ERROR
org.osgi.framework.BundleException: Unresolved constraint in bundleorg.restlet.
ext.json [14]: Unable to resolve 14.0: missing requirement [14.0]
osgi.wiring.pa
ckage; (osgi.wiring.package=org.json)
        at
org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382
6)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
        at
org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)

        at
org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart
LevelImpl.java:295)
        at java.lang.Thread.run(Unknown Source)
        at
org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)

        at
org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart
LevelImpl.java:295)
        at java.lang.Thread.run(Unknown Source)

Neither of these archives is mine. What is the best way to proceed?

Thanks.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message