felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joel Schuster" <joel.schus...@gmx.com>
Subject RE: Problems upgrading iPOJO due to EXPAND_FRAMES
Date Tue, 23 Oct 2012 21:23:45 GMT
Clement,

Any ETA on new version of ipojo-plugin? 1.8.2 has issues with dividing
Interfaces from Implementations in separate projects and 1.8.4 has issues
with FRAMES.

Should we just go back to 1.8.0 as we can't use SNAPSHOT versions?

- Joel

> -----Original Message-----
> From: bengt.rodehav@gmail.com [mailto:bengt.rodehav@gmail.com] On
> Behalf Of Bengt Rodehav
> Sent: Sunday, October 21, 2012 1:32 PM
> To: users@felix.apache.org
> Subject: Re: Problems upgrading iPOJO due to EXPAND_FRAMES
> 
> Thanks for the info Clement,
> 
> /Bengt
> 
> 2012/10/20 Clement Escoffier <clement.escoffier@gmail.com>
> 
> > Hi,
> >
> > Yes it works in the 1.8.2 but you may have some issues on some classes.
> > The 1.8.4 has this bug on classes containing Frames. It's fixed in the
> > trunk (see https://issues.apache.org/jira/browse/FELIX-3539).
> > We're preparing a release right now (reviewing issues) and finalizing
the
> > contributions.
> >
> > Regards,
> >
> > Clement
> >
> > On 19 oct. 2012, at 12:47, Bengt Rodehav <bengt@rodehav.com> wrote:
> >
> > > Seems like it works if I use manipulator version 1.8.2. Is this the
> > > recommendation? It seems a bit weird not being able to use the latest
> > > version since I assume there is a reason why 1.8.4 was released?
> > >
> > > /Bengt
> > >
> > > 2012/10/19 Bengt Rodehav <bengt@rodehav.com>
> > >
> > >> I haven't upgraded iPojo for quite a while but attempted to do this
> > today.
> > >> I want to use the latest versions which to my understanding is:
> > >>
> > >> - Core: 1.8.2
> > >> - Manipulator: 1.8.4
> > >> - Annotations: 1.8.2
> > >> - Maven plugin: 1.8.4
> > >> - Webconsole: 1.6.0
> > >>
> > >> However, doing this gives me the following build error:
> > >>
> > >> *[ERROR] Failed to execute goal
> > >> org.apache.felix:maven-ipojo-plugin:1.8.4:ipojo-b**undle (default) on
> > >> project notification-service: Execution default of goal
> > org.a**pache.felix:maven-ipojo-plugin:1.8.4:ipojo-bundle
> > >> failed: ClassReader.accept() s**hould be called with EXPAND_FRAMES
> flag
> > >> -> [Help 1]*
> > >>
> > >> I googled this problem and found:
> > >>
> > >>
> > >>
> > http://apache-felix.18485.n6.nabble.com/iPOJO-Maven-Plugin-throwing-
> exception-td4998339.html
> > >>
> > >> The above implies that this has been fixed in head after version
1.8.4
> > of
> > >> the manipulator. However, I cannot find a later release than 1.8.4 of
> > the
> > >> manipulator. How can I work around this problem? Is it possible to
> > release
> > >> the manipulator to provide a fix to this problem?
> > >>
> > >> /Bengt
> > >>
> >
> >


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message