felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Bosschaert <david.bosscha...@gmail.com>
Subject Re: OSGi 4.3 and Felix 4.0: is PackageAdmin.refreshPackages() obsolete?
Date Tue, 24 Jul 2012 15:11:02 GMT
On 24 July 2012 15:42, Richard S. Hall <heavy@ungoverned.org> wrote:
>
> On 7/24/12 10:16 , Christopher BROWN wrote:
>>
>> Hi Richard,
>>
>> Looking at:
>>
>> http://www.osgi.org/javadoc/r4v43/core/org/osgi/framework/Bundle.html#adapt(java.lang.Class)
>>
>> ...I don't see any specific mention of the special case for the system
>> bundle.  Of course, I don't doubt it :-)  but is this detailed somewhere?
>
>
> Yeah, I know, it sucks. This is one of the reasons I was against this whole
> "adapt()" approach, but people didn't listen to me. :-)
>
> Checkout the documentation for FrameworkWiring...

FYI - I added a bug for this to the OSGi bugzilla:
https://www.osgi.org/bugzilla/show_bug.cgi?id=149

Best regards,

David

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message