felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sahoo <sanjeeb.sa...@oracle.com>
Subject Re: Glassfish Server 3.1.1 deadlock using SCR snapshot jar built from trunk
Date Wed, 11 Jul 2012 14:36:55 GMT
Nick,

Can you run jstack against glassfish process and attach the output? 
Something like the following should suffice:

jstack `jps | egrep -i "glassfish|ASMain" | cut -f 1 -d " "`

Thanks,
Sahoo
On Wednesday 11 July 2012 07:10 PM, Nick Marcucci wrote:
> I'm currently working on a project in which I'm running a web bundle in a
> Glassfish 3.1.1 server instance. I ran into a problem with my web bundle
> declaring a declarative service. I saw from the mailing lists that someone
> suggested using a build from the trunk. I did so and replaced the SCR jar
> with the snapshot jar built from the trunk (I believe version 1.6.1).
>
> This solved my problem but introduced a peculiar error. Only when trying to
> update my existing web bundle using the OSGI console the Glassfish server
> freezes. After this, I am unable to use any of the features of the
> Glassfish server. The only remedy has been to restart the server.
>
> I reinstalled the old SCR bundle that comes with Glassfish and the SCR
> version 1.6.0 and did not experience this problem.
>
> Any ideas why this would hang the server?
>
> Thanks,
> Nick
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message