felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sahoo <sanjeeb.sa...@oracle.com>
Subject bundle-plugin and version of an exported package that's inlines from a bundle
Date Sat, 07 Jul 2012 06:51:06 GMT
In order to produce a self-sufficient bundle, I would like to package 
classes from another bundle in my bundle. I would also like to export 
the packages from my bundle, but I don't want to manage their version in 
my bundle as they are already present in the other bundle. 
Embed-Dependency works great as far as packaging is concerned, but it is 
not exporting the packages with correct versions. Is this a missing 
feature or am I not configuring things correctly? I do see the 
Import-Package getting generated with proper version ranges though.

Thanks,
Sahoo

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message