felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brunner Basil <ba...@entwinemedia.com>
Subject javax.xml.stream constraint violation
Date Wed, 14 Mar 2012 11:19:47 GMT
Hi,

when I start Felix, I get this error message:

====
ERROR: Bundle matterhorn-kernel [23] Error starting file:///opt/captureagent/ext/matterhorn-kernel-1.3-rc6.jar
(org.osgi.framework.BundleException: Uses constraint violation. Unable to resolve bundle revision
matterhorn-kernel [23.0] because it is exposed to package 'javax.xml.stream' from bundle revisions
org.apache.servicemix.specs.stax-api-1.0 [41.0] and org.apache.felix.framework [0] via two
dependency chains.

Chain 1:
  matterhorn-kernel [23.0]
    import: (&(osgi.wiring.package=javax.xml.stream)(version>=1.0.0))
     |
    export: osgi.wiring.package=javax.xml.stream
  org.apache.servicemix.specs.stax-api-1.0 [41.0]

Chain 2:
  matterhorn-kernel [23.0]
    import: (&(osgi.wiring.package=org.springframework.util.xml)(version>=3.0.0))
     |
    export: osgi.wiring.package=org.springframework.util.xml; uses:=javax.xml.stream
  org.springframework.core [12.0]
    import: (&(osgi.wiring.package=javax.xml.stream)(version>=0.0.0))
     |
    export: osgi.wiring.package=javax.xml.stream
  org.apache.felix.framework [0])
====

I don't completely understand the error message. Is there a (easy) way to solve this?

-Basil


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message