felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clement Escoffier <clement.escoff...@gmail.com>
Subject Re: ClassNotFoundException when using Ipojo maven plugin (1.8.2 only)
Date Sat, 11 Feb 2012 15:01:07 GMT
Hi,

This is a bug in 1.8.2 (critical by the way). Just use the 1.8.0, or use the 1.9.0-SNAPSHOT
(trunk) containing the fix. Both version works on Java 6. If you're using JAva 7, you need
to launch your JVM with the -XXusesplitverifier option.

Regards,

Clement

On 11.02.2012, at 02:29, Asaf Shakarzy wrote:

> Hey,
> I'm trying to setup ipojo correctly,
> 
> I have a 'impl' maven module which is dependent on an 'api' module
> The api module simply  contains some interfaces and is packed as a felix
> OSGI bundle,
> 
> I added to my 'service' maven module a dependency on the 'ipojo plugin' ver
> 1.8.2
> 
> When building, I get the following exception:
> 
> [ERROR] Failed to execute goal
> org.apache.felix:maven-ipojo-plugin:1.8.2:ipojo-bundle (default) on project
> com.myproject.felix.impl: Execution default of goal
> org.apache.felix:maven-ipojo-plugin:1.8.2:ipojo-bundle failed:
> java.lang.ClassNotFoundException: com.myproject.felix.api.Record -> [Help 1]
> 
> I declared 1 component in the metadata.xml which uses the 'Record'
> interface in some of its methods,
> 
> 
> btw, this is happening with ipojo maven plugin 1.8.2 only, I switched to
> 1.8.0 and this does not happen,
> 
> 
> 
> 
> Thanks,
> 
> Asaf.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message