felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julien Martin <bal...@gmail.com>
Subject Beginner needs help with maven-bundle-plugin
Date Thu, 15 Dec 2011 12:39:56 GMT
Hello,
I have read the documentation and I am desperately trying to
get maven-bundle-plugin to generate an appropriate manifest file for my jar.
Here is the plugin snippet from the POM:
            <plugin>
                <groupId>org.apache.felix</groupId>
                <artifactId>maven-bundle-plugin</artifactId>
                <extensions>true</extensions>
            </plugin>
The problem is that I always get the following manifest:
*Manifest-Version: 1.0*
*Archiver-Version: Plexus Archiver*
*Created-By: Apache Maven*
*Built-By: julien*
*Build-Jdk: 1.6.0_26*

Without any osgi information beeing added. I use mvn 2.2.1
Can anyone please help me?
Regards,
Julien.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message