felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <thieba...@artenum.com>
Subject missing requirement apple.awt
Date Fri, 11 Nov 2011 11:15:19 GMT
Hi list,

I have an error message when starting a bundle on Mac OS X:

missing requirement [19.0] package; (package=apple.awt) [caused by: Unable to resolve 1.0:
missing requirement [1.0] host; (bundle-symbolic-name=system.bundle)]

I know there is a problem with AWT on OS X, as I explained here:
http://dev.artenum.com/blog/ben/posts/osgi_vtk_and_macosx
and as discussed here:
http://www.mail-archive.com/users@felix.apache.org/msg08864.html

This is why I created the bundle that is numbered 1 in my felix instance:
1|Installed  |    1|Apple AWT export module (1.0.0)

This is an empty jar with the following manifest :
Manifest-Version: 1.0
Export-Package: apple.awt
Fragment-Host: system.bundle
Bundle-Version: 1.0.0
Bundle-Name: Apple AWT export module
Created-By: 1.6.0_22 (Apple Inc.)
Bundle-ManifestVersion: 2
Bundle-SymbolicName: apple.awt

But when I run the gogo command:
inspect package capability apple.awt

I have:
apple.awt [1] exports packages:
-------------------------------
Nothing

Which seems inconsistent with the bundle manifest.

I also changed the configuration file by adding:
org.osgi.framework.bootdelegation=apple.*

without success.

Any idea why it does not work?

Kind regards


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message