felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benoît Thiébault <thieba...@artenum.com>
Subject How to know what version of the framework is available?
Date Tue, 04 Oct 2011 08:54:00 GMT
Hi,

When starting my bundle, I have the following error:

org.osgi.framework.BundleException: Unresolved constraint in bundle
org-keridwen-vtk-linux64b [12]: Unable to resolve 12.0: missing
requirement [12.0] package;
(&(package=org.osgi.framework)(version>=1.6.0)(!(version>=2.0.0)))

In the bundle manifest, I have the following entry:
<Import-Package>
org.osgi.framework,
javax.swing.*
</Import-Package>

The osgi framework is set as an import, but no version is provided.
How can I know what version to set here? I guess it depends on my felix
install? How do I know what version is exported by the my felix
framework?

Kind regards

Ben


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message