felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From clement escoffier <clement.escoff...@gmail.com>
Subject Re: ipojo services within a war
Date Sat, 30 Jul 2011 10:17:28 GMT
Hi,

You should see in the log is the manipulation occurs or not.

Could you try with:
<plugin>
     <groupId>org.apache.felix</groupId>
     <artifactId>maven-ipojo-plugin</artifactId>
     <version>1.8.0</version>
     <executions>
         <execution>
              <goals>
                 <goal>ipojo-bundle</goal>
              </goals>
              <phase>package</phase>
         </execution>
     </executions>
     <dependencies>
<groupId>org.apache.felix</groupId>
<artifactId>org.apache.felix.ipojo.manipulator</artifactId>
 <version>1.9.0-SNAPSHOT</version>
</dependencies>
</plugin>

It will use a 'not-yet-released' version of the manipulator. If you can't
resolve it add the following repository to your pom file:
https://repository.apache.org/content/repositories/snapshots

Regards,

Clement

2011/7/29 Nguyen, Liem Manh <liem_m_nguyen@hp.com>

> Hello,
>
> I have a service exposed and instantiated via iPOJO annotations within a
> war file.  However, I do not see the service being published correctly (as I
> would if I package it in a bundle/jar file).  Here is my ipojo plugin
> configuration:
>
>                                                <plugin>
>
>  <groupId>org.apache.felix</groupId>
>
>  <artifactId>maven-ipojo-plugin</artifactId>
>
>  <version>1.8.0</version>
>                                                                <executions>
>
>    <execution>
>
>                    <goals>
>
>                                    <goal>ipojo-bundle</goal>
>
>                    </goals>
>
>                    <phase>package</phase>
>
>    </execution>
>
>  </executions>
>                                                </plugin>
>
> I am not sure if this is related to bug FELIX-2825 or not.  If it is, what
> version of maven-ipojo-plugin was the bug fixed in?  It seems to indicate
> 1.8.2; but, the latest on the Maven repo is 1.8.0.
>
> Thanks,
> Liem
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message