felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Katz <pytholog...@gmail.com>
Subject How can I get a compatible version syntax in Manifest.MF from the maven-bundle-plugin Plugin? The new one generates new syntax that can't be read by ServiceMix
Date Sat, 04 Jun 2011 00:24:21 GMT
I am having a problem where the org.apache.felix  maven-bundle-plugin which
generates version syntax that is not compatible with the Apache ServiceMix
OSGI container.   It won't deploy.



A previous version of the plug-in generated the version syntax as "X.Y" in
MANIFEST.MF


Import-Package: edu.berkeley.ist.sws.common.dbcp;resolution:=optional,
 edu.berkeley.sws.common.domain;resolution:=optional,edu.berkeley.sws.
 coursebf;resolution:=optional,edu.berkeley.sws.coursebf.domain;resolu
 tion:=optional,javax.sql;resolution:=optional,javax.xml.bind.annotati
 on;resolution:=optional,org.apache.commons.lang.builder;resolution:=o
 ptional;version="2.4",org.springframework.beans.factory;resolution:=o
 ptional;version="2.5",org.springframework.beans.factory.config;resolu
 tion:=optional;version="2.5",org.springframework.jdbc.core;resolution
 :=optional;version="3.0"

A new version of the plug-in generates the version syntax "[X.Y,Z)" in
MANIFEST.MF

Import-Package: edu.berkeley.ist.sws.common.dbcp;resolution:=optional,
 edu.berkeley.sws.common.domain;resolution:=optional,edu.berkeley.sws.
 coursebf.domain;resolution:=optional,javax.sql;resolution:=optional,j
 avax.xml.bind.annotation;resolution:=optional,org.apache.commons.lang
 .builder;resolution:=optional;version="[2.4,3)",org.springframework.b
 eans.factory;resolution:=optional;version="[2.5,3)",org.springframewo
 rk.beans.factory.config;resolution:=optional;version="[2.5,3)",org.sp
 ringframework.jdbc.core;resolution:=optional;version="[3.0,4)"

This syntax can not be read by Apache ServiceMix 4.3 and the jar will not
deploy successfully.  Instead it gets a class not found because one of the
packages is not successfully exported or imported.

What does open-bracket X dot Y comma Z close-paren actually mean?

Questions:
1. Is there a way to force the plugin to use the older version="X.Y" syntax?
2. Is there a way to specify a version of the plug into generate the older
syntax?
3. Is there a way to specify an older version of bndlib?
I have bndlib 0.0.357 in my repository but the install insists on picking up
version 1.15.0 instead.

If there is another forum I should try also, let me know.

We are deploying into apache-servicemix-4.3.0-fuse-03-00
I have also tried apache-servicemix-4.3.1-fuse-01-09
and apache-servicemix-4.3.0


Thanks!

Regards,

Richard Katz

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message