felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Hughes <hughes.m...@gmail.com>
Subject Provider Version Policy
Date Mon, 06 Jun 2011 18:39:51 GMT
I'm trying to configure a separate version policy for providers vs
consumers as described here (http://www.aqute.biz/Bnd/Versioning).

However, I can't seem to get maven-bundle-plugin and/or bnd to
cooperate.  Here is my bundle-plugin config:

        <plugin>
          <groupId>org.apache.felix</groupId>
          <artifactId>maven-bundle-plugin</artifactId>
          <version>2.3.4</version>
          <extensions>true</extensions>
          <configuration>
            <instructions>
              <_versionpolicy>[$(version;===;$(@)),$(version;+;$(@)))</_versionpolicy>
              <_providerversionpolicy>[$(version;===;$(@)),$(version;=+;$(@)))</_providerversionpolicy>
              <_provider_policy>[$(version;===;$(@)),$(version;=+;$(@)))</_provider_policy>
            </instructions>
          </configuration>
        </plugin>

I couldn't find docs on the mbp's website detailing acceptable values
for the <instructions> tag, so I tried some logical combinations for
-provider-policy.

Here is my osgi.bnd file that is trying to mark a package as a provider:

Export-Package: org.osgi.service.event;provide:=true


Now with that configured, the import range for that package should be
[1.5,1.6); instead it uses the regular version policy of [1.5,2).  Any
ideas?  Am I missing where the docs are located detailing the various
<instructions> flags?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message