felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard S. Hall" <he...@ungoverned.org>
Subject Re: Felix/pax runner cyclic dependency issue - whats the common way to solve this?
Date Wed, 18 May 2011 16:40:05 GMT
[removing the cross posting]

You have a few choices:

   1. Resolve bundle 33 before 88, which will raise the priority of its
      javax.transaction.xa package.
   2. Modify 88's import of javax.transaction.xa to include a version
      range that excludes 0.0.0 (i.e., the system bundle).
   3. Modify the framework to not export javax.transaction.xa (i.e.,
      create an org.osgi.framework.system.packages property in
      conf/config.properties that doesn't include it -- you can just
      copy this property from the default.properties file inside the
      Felix framework JAR file and remove the offending package).

-> richard


On 5/18/11 11:55, Matt Madhavan wrote:
> Hello,
> I ran into a strange issue today. I'm running Felix container (3.2.0) 
> with some provisioned bundles by invoking *mvn pax:provision*
>
> The OpenJpa bundle does not resolve (its in the installed stage!). I 
> see the following issue in the Felix console!
>
> [qtp9097155-32 - /system/console/bundles/87] WARN / - 
> %bundles.pluginTitle: Cann
> ot start
> org.osgi.framework.BundleException: Unable to resolve module 
> org.apache.openjpa
> [87.0] because it is exposed to package 'javax.transaction.xa' from 
> org.apache.g
> eronimo.specs.geronimo-jta_1.1_spec [33.0] and 
> org.apache.felix.framework [0] vi
> a two dependency chains.
>
> *Chain 1:*
> *  org.apache.openjpa [87.0]*
> *    import: 
> (&(package=javax.transaction.xa)(version>=1.1.0)(!(version>=1.2.0)))*
> *
> *
> *     |*
> *    export: package=javax.transaction.xa*
> *  org.apache.geronimo.specs.geronimo-jta_1.1_spec [33.0]*
> *
> *
> *Chain 2:*
> *  org.apache.openjpa [87.0]*
> *    import: (&(package=javax.jms)(version>=1.1.0)(!(version>=1.2.0)))*
> *     |*
> *    export: package=javax.jms; uses:=javax.transaction.xa*
> *  org.apache.geronimo.specs.geronimo-jms_1.1_spec [88.0]*
> *    import: (package=javax.transaction.xa)*
> *     |*
> *    export: package=javax.transaction.xa*
> *  org.apache.felix.framework [0]*
>
> _So Obviously javax.transaction.xa is getting resolved from two places;_
>
>    1.  How do I fix (or whats the best way to fix this issue) ?
>    2. Does Felix framework even export javax.transaction.xa ? I did
>       not see any reference to the javax.transaction.xa inside the
>       org.apache.felix.main_3.2.0.jar?
>
> I'm really confused now? Any idea/help will be appreciated.
>
> Thanks
> Matt
>
>
> _______________________________________________
> general mailing list
> general@lists.ops4j.org
> http://lists.ops4j.org/mailman/listinfo/general

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message