felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay McCoy ...@claymccoy.com>
Subject resolving transitive dependencies from bundle in Eclipse
Date Mon, 17 Jan 2011 19:25:52 GMT
First, a description of my two projects.  The pomfirst, and the Tycho
project that depends on it:

* I have a pomfirst project built with maven-bundle-plugin and depending on
guava.jar.  I use Embed dependency to actually include the guava.jar.  This
pomfist bundle is put in a p2 repo.

* I also have aTycho RCP project that uses the pomfirst bundle described
above by referencing the p2 repo in a .target file.  It has a bundle with
junit tests and a ui bundle that starts a basic application.  Both the test
and the ui call methods in the pomfirst project that use guava.

Everything works perfectly on the command line builds.  However, in Eclipse
there are cases where I get runtime exceptions that guava can't be found.
 Confusingly, I get different behavior whether I am running the test or UI
bundle.  The other variable is whether I am using the pomfirst bundle in the
p2 repo, or if I import it into the Eclipse IDE.  Below is a list of which
of the 4 combinations work and which result in a Runtime exception about
Guava.
Is this expected?  Is there anything I can do to fix the cases with Runtime
Exceptions?

These run:
RCP junit bundle ->  pomfirst bundle in IDE
RCP ui bundle -> pomfirst bundle in P2 rep

These fail to resolve guava at runtime.
RCP junit bundle -> pomfirst bundle in P2 repo
RCP ui bundle -> pomfirst bundle in IDE

Thanks,
Clay

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message