felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alasdair Nottingham <...@apache.org>
Subject Problem with 2.2.0 of the maven bundle plugin
Date Tue, 04 Jan 2011 10:40:36 GMT
Hi,

In aries we are currently using 2.2.0 of the maven bundle plugin. One
of our projects builds a WAB, so I updated it to set <_wab/> to have a
WAB built, but the content is not right. The jar looks like this:

WEB-INF/
WEB-INF/classes/
WEB-INF/classes/images/
WEB-INF/classes/images/Arieslogo_Horizontal.gif
WEB-INF/classes/images/BigBullet.png
WEB-INF/classes/images/apache-incubator-logo.png
WEB-INF/classes/images/bg.png
WEB-INF/classes/images/bg02-purple-left.png
WEB-INF/classes/images/bg02-purple-right.png
WEB-INF/classes/images/bg02-white-left-nogr.png
WEB-INF/classes/images/bg02-white-right-nogr.png
WEB-INF/classes/images/left-box-bottom.png
WEB-INF/classes/images/left-box-right.png
WEB-INF/classes/images/left-box-top.png
WEB-INF/classes/org/
WEB-INF/classes/org/apache/
WEB-INF/classes/org/apache/aries/
WEB-INF/classes/org/apache/aries/samples/
WEB-INF/classes/org/apache/aries/samples/blog/
WEB-INF/classes/org/apache/aries/samples/blog/web/
WEB-INF/classes/org/apache/aries/samples/blog/web/AddComment.class
WEB-INF/classes/org/apache/aries/samples/blog/web/AddCommentForm.class
WEB-INF/classes/org/apache/aries/samples/blog/web/CreateBlogEntry.class
WEB-INF/classes/org/apache/aries/samples/blog/web/CreateBlogEntryForm.class
WEB-INF/classes/org/apache/aries/samples/blog/web/EditAuthor.class
WEB-INF/classes/org/apache/aries/samples/blog/web/EditAuthorForm.class
WEB-INF/classes/org/apache/aries/samples/blog/web/ViewAuthor.class
WEB-INF/classes/org/apache/aries/samples/blog/web/ViewBlog.class
WEB-INF/classes/org/apache/aries/samples/blog/web/util/
WEB-INF/classes/org/apache/aries/samples/blog/web/util/FormServlet.class
WEB-INF/classes/org/apache/aries/samples/blog/web/util/FormatChecker.class
WEB-INF/classes/org/apache/aries/samples/blog/web/util/HTMLOutput.class
WEB-INF/classes/org/apache/aries/samples/blog/web/util/JNDIHelper.class
WEB-INF/classes/style/
WEB-INF/classes/style/blog.css
WEB-INF/web.xml
index.html

The problem is the WEB-INF/classes/style and WEB-INF/classes/images
directories should be in the root. The only thing that should be in
WEB-INF/classes are the classes. The index.html file is in the right
place. Does anyone kno what I should do to get the images and style in
the right place? The files are in src/main/resources.

Thanks
Alasdair

-- 
Alasdair Nottingham
not@apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message