felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eduardo García <egar...@swissms.ch>
Subject Re: Strange behavior
Date Wed, 15 Dec 2010 08:49:41 GMT

Hello.

Thanks for your help, both the little tip (well, maybe its little but I was
very annoyed with the inspect thing, so thanks a lot :P) and the log level
one.

Setting log.level to 4 didn't help, unfortunately, because I'm using
Glassfish and got myself into http://java.net/jira/browse/GLASSFISH-11443.

Anyway, I found the cause of this issue being a "password=GlassFish" added
to the ASM package bundled with Glassfish. I didn't know about that
directive, so that was my problem.

Again, thanks for your help.


Richard S. Hall wrote:
> 
> On 12/14/10 11:55, Eduardo García wrote:
>> Hello.
>>
>> I've wrapped a JAR using BND. This jar uses another package present in my
>> Felix installation, but it refuses to start. Here is the info:
>>
>> Capabilities of the needed package (org.objectweb.asm):
>>
>> ->  inspect package capability 27
> 
> p.s. You can save yourself some typing by doing "inspect p c 27" :-)
> 
>> org.glassfish.external.asm-all-repackaged [27] exports packages:
>> ----------------------------------------------------------------
>> org.objectweb.asm; version=3.1.0
>> org.objectweb.asm.commons; version=3.1.0
>> org.objectweb.asm.signature; version=3.1.0
>> org.objectweb.asm.tree; version=3.1.0
>>
>> Trying to start the offending package:
>> ->  start 256
>> org.osgi.framework.BundleException: Unresolved constraint in bundle
>> reflectasm-1.0 [256]: Unable to resolve 256.0: missing requirement
>> [256.0]
>> package; (&(package=org.objectweb.asm)(version>=3.1.0))
>>
>> Headers of the offending package:
>> ->  headers 256
>>
>> reflectasm-1.0 (256)
>> --------------------
>> Bnd-LastModified = 1292343495549
>> Bundle-ManifestVersion = 2
>> Bundle-Name = reflectasm-1.0
>> Bundle-SymbolicName = reflectasm-1.0
>> Bundle-Version = 1.0
>> Created-By = 1.6.0_22 (Apple Inc.)
>> Export-Package =
>> com.esotericsoftware.reflectasm;uses:="org.objectweb.asm"
>> Import-Package =
>> com.esotericsoftware.reflectasm,org.objectweb.asm;version="3.1"
>> Manifest-Version = 1.0
>> Tool = Bnd-0.0.384
>> ->
>>
>> Using "version" or not doesn't make any difference.
>>
>> Am I missing something? Thanks in advance!
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
> For additional commands, e-mail: users-help@felix.apache.org
> 
> 
> 

-- 
View this message in context: http://old.nabble.com/Strange-behavior-tp30456596p30461971.html
Sent from the Apache Felix - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message