felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ext2" <x...@tongtech.com>
Subject Re: the required-bundles' class cannot be resolved, what's the exact reason cause this?
Date Fri, 05 Nov 2010 03:09:31 GMT
Sorry, I forget to tell that: my usage is very simple , there is not
split-package exists, also didn't use  the bundle's version to choice
required bundle, just using the bundle's symbolic-name to choice the
required bundle;

======================================================================
Hi:
	Recently, I encounter a very simple usage for required-bundle. But
the class in required-bundle cannot be resolved and a
java.lang.NoClassDefFoundError raised. 
	When I using felix framework 3.0.1 , I find that just the bundle I
made cannot be required, but the other bundle etc: spring-beans can be
required; If I switch to felix framework 3.0.2, the bundle I made  also
could be required.
	I have tried to search the felix's issues , but cannot find
some-things concern of this. 
	Can any-one help me to point out what's the exact reason caused my
bundle cannot be required in felix framework 3.0.1?

	Following is my bundles and it's header:
	
Bundle: be-required:
	Contribute a package " com.tongtech.ti.be.require" 
Bundle: be-required's Manifest:
Manifest-Version: 1.0
Bundle-Name: Unnamed - test:be.require:bundle:1.0
Build-Jdk: 1.5.0_22
Built-By: ext2xhb
Created-By: Apache Maven Bundle Plugin
Import-Package: com.tongtech.ti.be.require
Bundle-ManifestVersion: 2
Bundle-SymbolicName: test.be.require
Tool: Bnd-0.0.357
Bnd-LastModified: 1288922744796
Export-Package: com.tongtech.ti.be.require
Bundle-Version: 1.0.0

Bundle requiring's manifest:
Manifest-Version: 1.0
Built-By: ext2xhb
Created-By: Apache Maven Bundle Plugin
Bundle-Activator: com.tongtech.ti.test.require.bundle.a.TestRequireAct
 ivator
Import-Package: com.tongtech.ti.test.require.bundle.a,org.osgi.framewo
 rk
Bnd-LastModified: 1288922762062
Export-Package: com.tongtech.ti.test.require.bundle.a;uses:="org.osgi.
 framework"
Bundle-Version: 1.0
Bundle-Name: Unnamed - test:require.bundlea:bundle:1.0
Build-Jdk: 1.5.0_22
Bundle-ManifestVersion: 2
Bundle-SymbolicName: test.require.bundlea
Tool: Bnd-0.0.357
Require-Bundle: test.be.require
	
		



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@felix.apache.org
For additional commands, e-mail: users-help@felix.apache.org


Mime
View raw message