felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Brind <bri...@brindy.org.uk>
Subject servlet bridge problem
Date Tue, 06 Apr 2010 23:00:38 GMT
Hi,

I'm trying to migrate from Equinox's servlet bridge to Felix's and have
followed the instructions on this page:
http://felix.apache.org/site/apache-felix-http-service.html#ApacheFelixHTTPService-UsingtheServletBridge

However, I'm deviating from the given example slightly by using a servlet
mapping of /osgi/* instead of just /*.  My problem is that this seems to
stop the servlet bridge working properly.

So I modified the sample WAR file from the Felix downloads page to use that
servlet mapping and then tried to access /osgi/system/console - it prompts
for a username and password using BASIC Auth but beyond that I get a 404
error.  I suspect if I can get the Web console running like this, I should
be able to migrate my existing project with virtually no effort.

Has anyone else tried to do this and if so how did you get it to work?

If not, does anyone have any ideas?

I need to serve some static resources and a couple of servlets from the WAR
itself but the Proxy servlet seems to block all these with 404, hence my
reason for using the /osgi/* mapping.

Thanks in advance,

Cheers,
Chris

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message