felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart McCulloch <mccu...@gmail.com>
Subject Re: Re: [VOTE] release maven-bundle-plugin 2.0.0
Date Thu, 05 Mar 2009 07:41:25 GMT
2009/3/5 <Clovis.SERAGIOTTO@raibau.at>

> > well not really, the expected behaviour is that plugin dependencies
> > don't conflict with project dependencies
> I don't use maven-bundle-plugin as a plugin, but as a dependency (for a
> plugin that extends the maven-bundle-plugin), so the version conflict I
> got is correct. And since what I do is not the expected use of the
> maven-bundle-plugin, you are right, I cannot really expect that the
> dependencies will be updated.
>

ah, yes - Maven doesn't handle that scenario very well (ie. plugin
extension/inheritance)
the simplest solution would probably be for you to patch the bundleplugin
source locally

Cheers
>
> -- clovis
>

-- 
Cheers, Stuart

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message