felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter GardfjÀll" <peter.gardfj...@gmail.com>
Subject Re: org.osgi.compendium-1.2.0.jar + Spring-DM == NoClassDefFoundError
Date Sun, 23 Nov 2008 18:29:30 GMT
Hi Stuart,

I am running with version 1.4.0 of the Felix framework, version 1.2.0 of the
compendium bundle.

I kind of doubt that this is caused by some bug in the Felix framework
itself, since I actually tested the exact same bundle setup on an Equinox
runtime, which produced the same result (that is, an exception was thrown
with org.osgi.compendium-1.2.0.jar, while everything worked fine with
org.eclipse.osgi.services_3.1.200.v20070605.jar). I guess it is quite
unlikely that both frameworks would suffer from the same bug.

I was thinking more along the line of something being wrong with the
manifest of the compendium bundle (for instance, the "Dynamic-ImportPackage:
*" looks a bit dangerous; I don't claim to be an OSGi expert, but I have
read somewhere that dynamic imports are considered bad OSGi practice,
generally speaking).

Perhaps it is most likely that this is a bug in Spring-DM.
What do you think?

regards, Peter

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message