felix-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jaap Vriend" <jaap.vri...@gmail.com>
Subject Felix-1.4.0: option for eliminating from 'reasonable default' package list?
Date Tue, 11 Nov 2008 13:37:59 GMT
Hi,

In pre-1.4.0 releases, it was possible to indicate (per jre) which packages
to export, e.g.:
jre-1.5=, \
 javax.accessibility; \
 javax.activity; \
 [...]
 org.xml.sax.ext; \
 org.xml.sax.helpers; \
 version="1.5.0"

In a project I'm working on, the default set needs to be extended with 3
specific packages, which is easily done through:
# To append packages to the default set of exported system packages,
# set this value.
org.osgi.framework.system.packages.extra= \
 sun.rmi.server; \
 sun.rmi.transport; \
 sun.rmi.registry;

In this project, however, there were also 2 specific packages
('javax.transaction' and 'javax.transaction.xa') that were removed.
Is it required to copy / paste the complete package list to
'org.osgi.framework.system.packages' without those 2 or is there an option
similar to the one above for 'eliminating from the default set'?
The latter would have my preference, especially if the 'reasonable default'
package list could change between felix versions.

Kind regards,
Jaap Vriend

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message