felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FELIX-5659) Possible bug with Framework#listResources
Date Tue, 27 Jun 2017 12:39:00 GMT

     [ https://issues.apache.org/jira/browse/FELIX-5659?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Guillaume Nodet updated FELIX-5659:
-----------------------------------
    Component/s: Framework

> Possible bug with Framework#listResources
> -----------------------------------------
>
>                 Key: FELIX-5659
>                 URL: https://issues.apache.org/jira/browse/FELIX-5659
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework
>            Reporter: Guillaume Nodet
>
> I'm not completely sure what the behavior should be, but it seems to me not very understandable
that the following may not return the same thing when used for the system bundle:
> {code}
>    systemBundle.adapt(BundleWiring.class).listResources("META-INF/services", "javax.script.ScriptEngineFactory",
2)
> and
>   systemBundle.adapt(BundleWiring.class).getClassLoader().loadResources("META-INF/services/javax.script.ScriptEngineFactory")
> {code}
> On JDK 8, the second call correctly returns the nashorn javascript engine factory, but
it can't be found using the first call.
> Anyone knows if this is an expected behavior ?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message