felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Florian Brunner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-5652) Felix Framework hangs on shutdown
Date Thu, 29 Jun 2017 18:35:00 GMT

    [ https://issues.apache.org/jira/browse/FELIX-5652?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16068762#comment-16068762
] 

Florian Brunner commented on FELIX-5652:
----------------------------------------

[~karlpauls]: I tried to to build https://github.com/apache/felix (root: mvn clean install)

In the Apache Snapshot Repo I found now a recent binary version: https://repository.apache.org/content/groups/snapshots/org/apache/felix/org.apache.felix.framework/5.7.0-SNAPSHOT/

The fix seems to have solved the issue. Thanks!

>From an API point of view you still might want to consider to also stop all threads when
calling Framework.waitForStop(0)

>From the Javadoc:
{quote}Wait until this Framework has completely stopped. [...]{quote}

> Felix Framework hangs on shutdown
> ---------------------------------
>
>                 Key: FELIX-5652
>                 URL: https://issues.apache.org/jira/browse/FELIX-5652
>             Project: Felix
>          Issue Type: Bug
>          Components: Framework
>    Affects Versions: framework-5.6.2, framework-5.6.4
>            Reporter: Florian Brunner
>            Assignee: Karl Pauls
>            Priority: Blocker
>             Fix For: framework-5.6.6
>
>         Attachments: felix-5652-v4.6.0.zip, felix-5652-v5.6.2.zip
>
>
> When shutting down the Felix Framework the process hangs for about 1 minute or so.
> When running with the debugger, NetBeans shows 8 FelixResolver threads still running
(my machine has 8 cores, the number might be related).
> The issue did not occur with v4.6.0



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message