felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J.W. Janssen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-5603) Upgrade User Admin MongoDB Store to be compatible with mongo-java-driver 3.3.0
Date Tue, 28 Mar 2017 09:25:41 GMT

    [ https://issues.apache.org/jira/browse/FELIX-5603?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15944855#comment-15944855
] 

J.W. Janssen commented on FELIX-5603:
-------------------------------------

thanks, will take a look at it and apply your PR...

> Upgrade User Admin MongoDB Store to be compatible with mongo-java-driver 3.3.0
> ------------------------------------------------------------------------------
>
>                 Key: FELIX-5603
>                 URL: https://issues.apache.org/jira/browse/FELIX-5603
>             Project: Felix
>          Issue Type: Improvement
>          Components: User Admin
>            Reporter: Vladislav Potapov
>
> Current implementation of mongodb store in User Admin is based on mongo-java-driver version
2.8.0 that is incompatible with the MongoDB version 2.6 and above. 
> MongoClient initializaiton is now different and significant number of classes or methods
were marked as deprecated or removed. 
> In order to be compatible with the recent MongoDB versions and make it easier to update/maintain
it's required to upgrade to mongo-java-driver version 3.x.x



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message