felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ferry Huberts (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-5568) SCR contains compact3 profile code
Date Fri, 31 Mar 2017 13:58:41 GMT

    [ https://issues.apache.org/jira/browse/FELIX-5568?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15950935#comment-15950935
] 

Ferry Huberts commented on FELIX-5568:
--------------------------------------

Upon better inspection of the requirement it seems wrong.
It appears to exclude Java 1.7.

should probably be:

Require-Capability: osgi.ee; filter:="(| (&(osgi.ee=JavaSE)(version=1.6)) (&(osgi.ee=JavaSE)(version=1.7))
(&(osgi.ee=JavaSE/compact1)(version=1.8)) )"

But what to do with Java 1.9 (and up) ?

> SCR contains compact3 profile code
> ----------------------------------
>
>                 Key: FELIX-5568
>                 URL: https://issues.apache.org/jira/browse/FELIX-5568
>             Project: Felix
>          Issue Type: Bug
>          Components: Declarative Services (SCR)
>    Affects Versions: scr-2.0.8
>         Environment: Fedora 25 x64
>            Reporter: Ferry Huberts
>            Assignee: Carsten Ziegeler
>             Fix For: scr-2.1.0
>
>
> {quote}
> $ jdeps -P *.jar |grep compact3
> org.apache.felix.scr-2.0.8.jar -> /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.121-1.b14.fc25.x86_64/jre/lib/rt.jar
(compact3)
>       -> java.lang.management                               compact3
> {quote}
> Maybe split off the compact3 part as an optional extension/fragment?



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message