felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steinar Bang ...@dod.no>
Subject maven-bundle-plugin stopped working for version > 2.5.3
Date Fri, 20 Jan 2017 21:35:52 GMT
Platform: Windows 7
          Java 1.8
          maven 3.3.9

For version 2.5.3, this pom file creates an OSGi bundle with an

For later versions (I've only tried 2.5.4 (the version immediately
following the one I was using) and 3.2.0 (the currently newest version))
the jar file become a plain jar file (ie. not an OSGi bundle).

Does anyone know what could cause this?

There are no error messages, the only difference in the output from "mvn
clean install" is that the 2.5.3 version has this line, and the 2.5.4
version doesn't:
 [INFO] --- maven-bundle-plugin:2.5.3:bundle (bundle) @ ukelonn.bundle.test.db ---

The version for maven-bundle-plugin is set in the parent pom:

The output from maven-bundle-plugin 2.5.3 is here:

The output from maven-bundle-plugin 2.5.4 is here:

Thanks for anything that could lead me in the right direction!

- Steinar

View raw message