felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Bosschaert (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (FELIX-5395) Ship gogo 1.0.0 with JLine support as default in the Felix Distro
Date Tue, 08 Nov 2016 11:28:58 GMT

     [ https://issues.apache.org/jira/browse/FELIX-5395?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Bosschaert resolved FELIX-5395.
-------------------------------------
    Resolution: Fixed

Fixed in https://svn.apache.org/viewvc?view=revision&revision=1768663

> Ship gogo 1.0.0 with JLine support as default in the Felix Distro
> -----------------------------------------------------------------
>
>                 Key: FELIX-5395
>                 URL: https://issues.apache.org/jira/browse/FELIX-5395
>             Project: Felix
>          Issue Type: Improvement
>          Components: Main Distribution
>            Reporter: David Bosschaert
>            Assignee: David Bosschaert
>
> Now that we have gogo 1.0.0 with nice JLine support, command completion, colours, history
and more goodies, I think it would be nice to ship this as the default shell implementation
with Felix. 
> This would make the bundles that are pre-installed with the distro as follows:
> {code}g! lb                                                                  09:49:44
> START LEVEL 1
>    ID|State      |Level|Name
>     0|Active     |    0|System Bundle (5.7.0.SNAPSHOT)|5.7.0.SNAPSHOT
>     1|Active     |    1|JLine (3.0.1)|3.0.1
>     2|Active     |    1|Apache Felix Bundle Repository (2.0.8)|2.0.8
>     3|Active     |    1|Apache Felix Gogo Command (1.0.0)|1.0.0
>     4|Active     |    1|Apache Felix Gogo JLine Shell (1.0.0)|1.0.0
>     5|Active     |    1|Apache Felix Gogo Runtime (1.0.0)|1.0.0{code}
> It does bring in the new JLine dependency which requires Java 8. I think at this stage
most developers are using Java 8. For those that cannot use Java 8 they can use the alternative
Gogo shell that does not depend on JLine.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message