felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Bosschaert (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FELIX-5391) AbstractMethodError in bundlerepository due to wrong import range.
Date Wed, 16 Nov 2016 14:15:59 GMT

    [ https://issues.apache.org/jira/browse/FELIX-5391?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15670506#comment-15670506
] 

David Bosschaert commented on FELIX-5391:
-----------------------------------------

Thanks [~njbartlett]! The patch is applied in https://svn.apache.org/viewvc?view=revision&revision=1769986

> AbstractMethodError in bundlerepository due to wrong import range.
> ------------------------------------------------------------------
>
>                 Key: FELIX-5391
>                 URL: https://issues.apache.org/jira/browse/FELIX-5391
>             Project: Felix
>          Issue Type: Bug
>          Components: Bundle Repository (OBR)
>            Reporter: Neil Bartlett
>            Assignee: David Bosschaert
>             Fix For: bundlerepository-2.0.10
>
>
> Bundle org.apache.felix.bundlerepository imports package {{org.osgi.service.repository}}
using the range {{[1.0,2.0)}}. This is incorrect because it is a provider of that contract,
so the range should be {{[1.0,1.1)}}.
> At runtime this leads to AbstractMethodError because a client could wire to version 1.1
of the API and try to call one of the new methods such as {{Repository.newRequirementBuilder()}},
which is not implemented by Felix:
> {noformat}
> java.lang.AbstractMethodError: org.apache.felix.bundlerepository.impl.OSGiRepositoryImpl.newRequirementBuilder(Ljava/lang/String;)Lorg/osgi/service/repository/RequirementBuilder;
> {noformat}
> Affects version: 2.0.8 (not available in the JIRA dropdown for some reason).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message