felix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre De Rop <pierre.de...@gmail.com>
Subject Re: [VOTE] Release Apache Felix Config Admin 1.8.12
Date Tue, 25 Oct 2016 09:06:51 GMT
Hi

I reproduced the same issue reported by Karl, but only using java8.

But with java7, it's compiling fine for me.


/Pierre



On Tue, Oct 25, 2016 at 11:03 AM, Carsten Ziegeler <cziegeler@apache.org>
wrote:

> Karl Pauls wrote
> > Hm, this is another candidate for our NOTICE cleanup I guess but as we
> > discussed earlier I don't think that is a blocker (I really need to find
> > the time to look into it).
> >
> > However, I'm having some problems building the source (not sure what is
> > going on). If i:
> >
> > unzip org.apache.felix.configadmin-1.8.12-source-release.zip
> > cd org.apache.felix.configadmin-1.8.12
> > mvn clean install
> >
> > I'm getting all sorts of errors from the pax tests (some - but not all -
> of
> > the output inline after the break).
> >
> > Not sure what is going on - is this building for others?
> >
>
> Works perfectly for me, you're not using Java 9 I assume?
>
> Carsten
>
> > regards,
> >
> > Karl
> >
> > -------------------------------------------------------
> >
> >  T E S T S
> >
> > -------------------------------------------------------
> >
> > SLF4J: The requested version 1.6.99 by your slf4j binding is not
> compatible
> > with [1.5.5, 1.5.6, 1.5.7, 1.5.8, 1.5.9, 1.5.10, 1.5.11]
> >
> > SLF4J: See http://www.slf4j.org/codes.html#version_mismatch for further
> > details.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > Running org.apache.felix.cm.integration.ConfigUpdateStressTest
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > ERROR: Bundle org.ops4j.pax.exam [1] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam [1]: Unable to resolve 1.0: missing requirement [1.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam [1]: Unable to resolve 1.0: missing requirement [1.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam.rbc [2] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.rbc.link
> > (org.osgi.framework.BundleException: Activator start error in bundle
> > org.ops4j.pax.exam.rbc [2].)
> >
> > java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
> >
> > at org.ops4j.pax.exam.rbc.internal.Activator.<clinit>(Activator.java:47)
> >
> > at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
> >
> > at
> > sun.reflect.NativeConstructorAccessorImpl.newInstance(
> NativeConstructorAccessorImpl.java:62)
> >
> > at
> > sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
> DelegatingConstructorAccessorImpl.java:45)
> >
> > at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
> >
> > at java.lang.Class.newInstance(Class.java:442)
> >
> > at org.apache.felix.framework.Felix.createBundleActivator(
> Felix.java:4177)
> >
> > at org.apache.felix.framework.Felix.activateBundle(Felix.java:1972)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1895)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > Caused by: java.lang.ClassNotFoundException: org.slf4j.LoggerFactory not
> > found by org.ops4j.pax.exam.rbc [2]
> >
> > at
> > org.apache.felix.framework.BundleWiringImpl.
> findClassOrResourceByDelegation(BundleWiringImpl.java:1460)
> >
> > at
> > org.apache.felix.framework.BundleWiringImpl.access$400(
> BundleWiringImpl.java:72)
> >
> > at
> > org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(
> BundleWiringImpl.java:1843)
> >
> > at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
> >
> > ... 12 more
> >
> > ERROR: Bundle org.ops4j.pax.exam.inject [3] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.inject.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.inject [3]: Unable to resolve 3.0: missing requirement
> > [3.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.framework)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 10.0: missing requirement [10.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.inject [3]: Unable to resolve 3.0: missing requirement
> > [3.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.framework)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 10.0: missing requirement [10.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam.extender.service [4] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.extender.service.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.extender.service [4]: Unable to resolve 4.0: missing
> > requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.extender.service [4]: Unable to resolve 4.0: missing
> > requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.logging.pax-logging-api [6] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.logging.api.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.logging.pax-logging-api [6]: Unable to resolve 6.0:
> missing
> > requirement [6.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.xml.parsers))
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.logging.pax-logging-api [6]: Unable to resolve 6.0:
> missing
> > requirement [6.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.xml.parsers)
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.base [7] Error starting
> > link:classpath:META-INF/links/org.ops4j.base.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.base [7]: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.base [7]: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.swissbox.core [8] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.swissbox.core.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.core [8]: Unable to resolve 8.0: missing
> requirement
> > [8.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.core [8]: Unable to resolve 8.0: missing
> requirement
> > [8.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.swissbox.extender [9] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.swissbox.extender.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.extender [9]: Unable to resolve 9.0: missing
> > requirement [9.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.extender [9]: Unable to resolve 9.0: missing
> > requirement [9.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.swissbox.framework [10] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.swissbox.framework.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.framework [10]: Unable to resolve 10.0: missing
> > requirement [10.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.framework [10]: Unable to resolve 10.0: missing
> > requirement [10.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam.invoker.junit [14] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.invoker.junit.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.invoker.junit [14]: Unable to resolve 14.0: missing
> > requirement [14.0] osgi.wiring.package;
> > (osgi.wiring.package=org.ops4j.pax.exam.raw.extender) [caused by:
> Unable to
> > resolve 4.0: missing requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]]])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.invoker.junit [14]: Unable to resolve 14.0: missing
> > requirement [14.0] osgi.wiring.package;
> > (osgi.wiring.package=org.ops4j.pax.exam.raw.extender) [caused by:
> Unable to
> > resolve 4.0: missing requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]]]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.tinybundles [15] Error starting
> > mvn:org.ops4j.pax.tinybundles/tinybundles/1.0.0
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.tinybundles [15]: Unable to resolve 15.0: missing
> requirement
> > [15.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 6.0: missing requirement [6.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.tinybundles [15]: Unable to resolve 15.0: missing
> requirement
> > [15.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 6.0: missing requirement [6.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam [1] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam [1]: Unable to resolve 1.0: missing requirement [1.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam [1]: Unable to resolve 1.0: missing requirement [1.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam.rbc [2] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.rbc.link
> > (org.osgi.framework.BundleException: Activator start error in bundle
> > org.ops4j.pax.exam.rbc [2].)
> >
> > java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
> >
> > at org.ops4j.pax.exam.rbc.internal.Activator.<clinit>(Activator.java:47)
> >
> > at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
> >
> > at
> > sun.reflect.NativeConstructorAccessorImpl.newInstance(
> NativeConstructorAccessorImpl.java:62)
> >
> > at
> > sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
> DelegatingConstructorAccessorImpl.java:45)
> >
> > at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
> >
> > at java.lang.Class.newInstance(Class.java:442)
> >
> > at org.apache.felix.framework.Felix.createBundleActivator(
> Felix.java:4177)
> >
> > at org.apache.felix.framework.Felix.activateBundle(Felix.java:1972)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1895)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > Caused by: java.lang.ClassNotFoundException: org.slf4j.LoggerFactory not
> > found by org.ops4j.pax.exam.rbc [2]
> >
> > at
> > org.apache.felix.framework.BundleWiringImpl.
> findClassOrResourceByDelegation(BundleWiringImpl.java:1460)
> >
> > at
> > org.apache.felix.framework.BundleWiringImpl.access$400(
> BundleWiringImpl.java:72)
> >
> > at
> > org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(
> BundleWiringImpl.java:1843)
> >
> > at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
> >
> > ... 12 more
> >
> > ERROR: Bundle org.ops4j.pax.exam.inject [3] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.inject.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.inject [3]: Unable to resolve 3.0: missing requirement
> > [3.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.framework)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 10.0: missing requirement [10.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.inject [3]: Unable to resolve 3.0: missing requirement
> > [3.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.framework)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 10.0: missing requirement [10.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam.extender.service [4] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.extender.service.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.extender.service [4]: Unable to resolve 4.0: missing
> > requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.extender.service [4]: Unable to resolve 4.0: missing
> > requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.logging.pax-logging-api [6] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.logging.api.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.logging.pax-logging-api [6]: Unable to resolve 6.0:
> missing
> > requirement [6.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.xml.parsers))
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.logging.pax-logging-api [6]: Unable to resolve 6.0:
> missing
> > requirement [6.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.xml.parsers)
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.base [7] Error starting
> > link:classpath:META-INF/links/org.ops4j.base.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.base [7]: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.base [7]: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.swissbox.core [8] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.swissbox.core.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.core [8]: Unable to resolve 8.0: missing
> requirement
> > [8.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.core [8]: Unable to resolve 8.0: missing
> requirement
> > [8.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.swissbox.extender [9] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.swissbox.extender.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.extender [9]: Unable to resolve 9.0: missing
> > requirement [9.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.extender [9]: Unable to resolve 9.0: missing
> > requirement [9.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.swissbox.framework [10] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.swissbox.framework.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.framework [10]: Unable to resolve 10.0: missing
> > requirement [10.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.framework [10]: Unable to resolve 10.0: missing
> > requirement [10.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam.invoker.junit [14] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.invoker.junit.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.invoker.junit [14]: Unable to resolve 14.0: missing
> > requirement [14.0] osgi.wiring.package;
> > (osgi.wiring.package=org.ops4j.pax.exam.raw.extender) [caused by:
> Unable to
> > resolve 4.0: missing requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]]])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.invoker.junit [14]: Unable to resolve 14.0: missing
> > requirement [14.0] osgi.wiring.package;
> > (osgi.wiring.package=org.ops4j.pax.exam.raw.extender) [caused by:
> Unable to
> > resolve 4.0: missing requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]]]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.tinybundles [15] Error starting
> > mvn:org.ops4j.pax.tinybundles/tinybundles/1.0.0
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.tinybundles [15]: Unable to resolve 15.0: missing
> requirement
> > [15.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 6.0: missing requirement [6.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.tinybundles [15]: Unable to resolve 15.0: missing
> requirement
> > [15.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 6.0: missing requirement [6.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > Tests run: 2, Failures: 0, Errors: 2, Skipped: 0, Time elapsed: 20.632
> sec
> > <<< FAILURE! - in org.apache.felix.cm.integration.ConfigUpdateStressTest
> >
> > test_ManagedService_race_condition_test:org.apache.felix.cm.integration.
> ConfigUpdateStressTest.test_ManagedService_race_condition_
> test:NativeContainer:org.apache.felix.framework.FrameworkFactory@1ed4004b
> (org.apache.felix.cm.integration.ConfigUpdateStressTest)
> >  Time elapsed: 10.431 sec  <<< ERROR!
> >
> > org.ops4j.pax.swissbox.framework.ServiceLookupException: gave up waiting
> > for service org.ops4j.pax.exam.ProbeInvoker
> >
> > at
> > org.ops4j.pax.swissbox.framework.ServiceLookup.
> getService(ServiceLookup.java:161)
> >
> > at
> > org.ops4j.pax.swissbox.framework.ServiceLookup.
> getService(ServiceLookup.java:104)
> >
> > at
> > org.ops4j.pax.swissbox.framework.ServiceLookup.
> getService(ServiceLookup.java:87)
> >
> > at
> > org.ops4j.pax.exam.nat.internal.NativeTestContainer.
> call(NativeTestContainer.java:94)
> >
> > at
> > org.ops4j.pax.exam.spi.reactors.AllConfinedStagedReactor.invoke(
> AllConfinedStagedReactor.java:74)
> >
> > at
> > org.ops4j.pax.exam.junit.JUnit4TestRunner$2.evaluate(
> JUnit4TestRunner.java:285)
> >
> > at
> > org.junit.runners.BlockJUnit4ClassRunner.runChild(
> BlockJUnit4ClassRunner.java:70)
> >
> > at
> > org.junit.runners.BlockJUnit4ClassRunner.runChild(
> BlockJUnit4ClassRunner.java:44)
> >
> > at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:180)
> >
> > at org.junit.runners.ParentRunner.access$000(ParentRunner.java:41)
> >
> > at org.junit.runners.ParentRunner$1.evaluate(ParentRunner.java:173)
> >
> > at org.junit.runners.ParentRunner.run(ParentRunner.java:220)
> >
> > at org.ops4j.pax.exam.junit.JUnit4TestRunner.run(
> JUnit4TestRunner.java:94)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.execute(
> JUnit4Provider.java:283)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.executeWithRerun(
> JUnit4Provider.java:173)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.
> executeTestSet(JUnit4Provider.java:153)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.invoke(
> JUnit4Provider.java:128)
> >
> > at
> > org.apache.maven.surefire.booter.ForkedBooter.
> invokeProviderInSameClassLoader(ForkedBooter.java:203)
> >
> > at
> > org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(
> ForkedBooter.java:155)
> >
> > at org.apache.maven.surefire.booter.ForkedBooter.main(
> ForkedBooter.java:103)
> >
> >
> > test_ManagedServiceFactory_race_condition_test:org.
> apache.felix.cm.integration.ConfigUpdateStressTest.test_
> ManagedServiceFactory_race_condition_test:NativeContainer:org.apache.
> felix.framework.FrameworkFactory@1ed4004b(org.apache.felix.cm.integration.
> ConfigUpdateStressTest)
> >  Time elapsed: 10.153 sec  <<< ERROR!
> >
> > org.ops4j.pax.swissbox.framework.ServiceLookupException: gave up waiting
> > for service org.ops4j.pax.exam.ProbeInvoker
> >
> > at
> > org.ops4j.pax.swissbox.framework.ServiceLookup.
> getService(ServiceLookup.java:161)
> >
> > at
> > org.ops4j.pax.swissbox.framework.ServiceLookup.
> getService(ServiceLookup.java:104)
> >
> > at
> > org.ops4j.pax.swissbox.framework.ServiceLookup.
> getService(ServiceLookup.java:87)
> >
> > at
> > org.ops4j.pax.exam.nat.internal.NativeTestContainer.
> call(NativeTestContainer.java:94)
> >
> > at
> > org.ops4j.pax.exam.spi.reactors.AllConfinedStagedReactor.invoke(
> AllConfinedStagedReactor.java:74)
> >
> > at
> > org.ops4j.pax.exam.junit.JUnit4TestRunner$2.evaluate(
> JUnit4TestRunner.java:285)
> >
> > at
> > org.junit.runners.BlockJUnit4ClassRunner.runChild(
> BlockJUnit4ClassRunner.java:70)
> >
> > at
> > org.junit.runners.BlockJUnit4ClassRunner.runChild(
> BlockJUnit4ClassRunner.java:44)
> >
> > at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:180)
> >
> > at org.junit.runners.ParentRunner.access$000(ParentRunner.java:41)
> >
> > at org.junit.runners.ParentRunner$1.evaluate(ParentRunner.java:173)
> >
> > at org.junit.runners.ParentRunner.run(ParentRunner.java:220)
> >
> > at org.ops4j.pax.exam.junit.JUnit4TestRunner.run(
> JUnit4TestRunner.java:94)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.execute(
> JUnit4Provider.java:283)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.executeWithRerun(
> JUnit4Provider.java:173)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.
> executeTestSet(JUnit4Provider.java:153)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.invoke(
> JUnit4Provider.java:128)
> >
> > at
> > org.apache.maven.surefire.booter.ForkedBooter.
> invokeProviderInSameClassLoader(ForkedBooter.java:203)
> >
> > at
> > org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(
> ForkedBooter.java:155)
> >
> > at org.apache.maven.surefire.booter.ForkedBooter.main(
> ForkedBooter.java:103)
> >
> >
> > Running org.apache.felix.cm.integration.ConfigurationAdminUpdateStress
> Test
> >
> > [main] INFO org.ops4j.pax.exam.spi.DefaultExamSystem - Pax Exam System
> > (Version: 2.6.0) created.
> >
> > ERROR: Bundle org.ops4j.pax.exam [1] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam [1]: Unable to resolve 1.0: missing requirement [1.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam [1]: Unable to resolve 1.0: missing requirement [1.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam.rbc [2] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.rbc.link
> > (org.osgi.framework.BundleException: Activator start error in bundle
> > org.ops4j.pax.exam.rbc [2].)
> >
> > java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
> >
> > at org.ops4j.pax.exam.rbc.internal.Activator.<clinit>(Activator.java:47)
> >
> > at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
> >
> > at
> > sun.reflect.NativeConstructorAccessorImpl.newInstance(
> NativeConstructorAccessorImpl.java:62)
> >
> > at
> > sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
> DelegatingConstructorAccessorImpl.java:45)
> >
> > at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
> >
> > at java.lang.Class.newInstance(Class.java:442)
> >
> > at org.apache.felix.framework.Felix.createBundleActivator(
> Felix.java:4177)
> >
> > at org.apache.felix.framework.Felix.activateBundle(Felix.java:1972)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1895)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > Caused by: java.lang.ClassNotFoundException: org.slf4j.LoggerFactory not
> > found by org.ops4j.pax.exam.rbc [2]
> >
> > at
> > org.apache.felix.framework.BundleWiringImpl.
> findClassOrResourceByDelegation(BundleWiringImpl.java:1460)
> >
> > at
> > org.apache.felix.framework.BundleWiringImpl.access$400(
> BundleWiringImpl.java:72)
> >
> > at
> > org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(
> BundleWiringImpl.java:1843)
> >
> > at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
> >
> > ... 12 more
> >
> > ERROR: Bundle org.ops4j.pax.exam.inject [3] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.inject.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.inject [3]: Unable to resolve 3.0: missing requirement
> > [3.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.framework)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 10.0: missing requirement [10.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.inject [3]: Unable to resolve 3.0: missing requirement
> > [3.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.framework)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 10.0: missing requirement [10.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam.extender.service [4] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.extender.service.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.extender.service [4]: Unable to resolve 4.0: missing
> > requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.extender.service [4]: Unable to resolve 4.0: missing
> > requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.logging.pax-logging-api [6] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.logging.api.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.logging.pax-logging-api [6]: Unable to resolve 6.0:
> missing
> > requirement [6.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.xml.parsers))
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.logging.pax-logging-api [6]: Unable to resolve 6.0:
> missing
> > requirement [6.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.xml.parsers)
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.base [7] Error starting
> > link:classpath:META-INF/links/org.ops4j.base.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.base [7]: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl))
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.base [7]: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.swissbox.core [8] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.swissbox.core.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.core [8]: Unable to resolve 8.0: missing
> requirement
> > [8.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.core [8]: Unable to resolve 8.0: missing
> requirement
> > [8.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.swissbox.extender [9] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.swissbox.extender.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.extender [9]: Unable to resolve 9.0: missing
> > requirement [9.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.extender [9]: Unable to resolve 9.0: missing
> > requirement [9.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.swissbox.framework [10] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.swissbox.framework.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.framework [10]: Unable to resolve 10.0: missing
> > requirement [10.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.swissbox.framework [10]: Unable to resolve 10.0: missing
> > requirement [10.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.spi)(version>=1.3.0)(!(
> version>=2.0.0)))
> > [caused by: Unable to resolve 7.0: missing requirement [7.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.exam.invoker.junit [14] Error starting
> > link:classpath:META-INF/links/org.ops4j.pax.exam.invoker.junit.link
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.invoker.junit [14]: Unable to resolve 14.0: missing
> > requirement [14.0] osgi.wiring.package;
> > (osgi.wiring.package=org.ops4j.pax.exam.raw.extender) [caused by:
> Unable to
> > resolve 4.0: missing requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]]])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.exam.invoker.junit [14]: Unable to resolve 14.0: missing
> > requirement [14.0] osgi.wiring.package;
> > (osgi.wiring.package=org.ops4j.pax.exam.raw.extender) [caused by:
> Unable to
> > resolve 4.0: missing requirement [4.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.pax.swissbox.core)(
> version>=1.5.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 8.0: missing requirement [8.0]
> > osgi.wiring.package;
> > (&(osgi.wiring.package=org.ops4j.lang)(version>=1.3.0)) [caused by:
> Unable
> > to resolve 7.0: missing requirement [7.0] osgi.wiring.package;
> > (osgi.wiring.package=javax.net.ssl)]]]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > ERROR: Bundle org.ops4j.pax.tinybundles [15] Error starting
> > mvn:org.ops4j.pax.tinybundles/tinybundles/1.0.0
> > (org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.tinybundles [15]: Unable to resolve 15.0: missing
> requirement
> > [15.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 6.0: missing requirement [6.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])
> >
> > org.osgi.framework.BundleException: Unresolved constraint in bundle
> > org.ops4j.pax.tinybundles [15]: Unable to resolve 15.0: missing
> requirement
> > [15.0] osgi.wiring.package;
> > (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0)))
> > [caused by: Unable to resolve 6.0: missing requirement [6.0]
> > osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
> >
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:3826)
> >
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
> >
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
> >
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:295)
> >
> > at java.lang.Thread.run(Thread.java:745)
> >
> > Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 10.099
> sec
> > <<< FAILURE! - in
> > org.apache.felix.cm.integration.ConfigurationAdminUpdateStressTest
> >
> > testCMUpdateStress:org.apache.felix.cm.integration.
> ConfigurationAdminUpdateStressTest.testCMUpdateStress:
> NativeContainer:org.apache.felix.framework.FrameworkFactory@7bedc48a(org.
> apache.felix.cm.integration.ConfigurationAdminUpdateStressTest)
> >  Time elapsed: 10.099 sec  <<< ERROR!
> >
> > org.ops4j.pax.swissbox.framework.ServiceLookupException: gave up waiting
> > for service org.ops4j.pax.exam.ProbeInvoker
> >
> > at
> > org.ops4j.pax.swissbox.framework.ServiceLookup.
> getService(ServiceLookup.java:161)
> >
> > at
> > org.ops4j.pax.swissbox.framework.ServiceLookup.
> getService(ServiceLookup.java:104)
> >
> > at
> > org.ops4j.pax.swissbox.framework.ServiceLookup.
> getService(ServiceLookup.java:87)
> >
> > at
> > org.ops4j.pax.exam.nat.internal.NativeTestContainer.
> call(NativeTestContainer.java:94)
> >
> > at
> > org.ops4j.pax.exam.spi.reactors.AllConfinedStagedReactor.invoke(
> AllConfinedStagedReactor.java:74)
> >
> > at
> > org.ops4j.pax.exam.junit.JUnit4TestRunner$2.evaluate(
> JUnit4TestRunner.java:285)
> >
> > at
> > org.junit.runners.BlockJUnit4ClassRunner.runChild(
> BlockJUnit4ClassRunner.java:70)
> >
> > at
> > org.junit.runners.BlockJUnit4ClassRunner.runChild(
> BlockJUnit4ClassRunner.java:44)
> >
> > at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:180)
> >
> > at org.junit.runners.ParentRunner.access$000(ParentRunner.java:41)
> >
> > at org.junit.runners.ParentRunner$1.evaluate(ParentRunner.java:173)
> >
> > at org.junit.runners.ParentRunner.run(ParentRunner.java:220)
> >
> > at org.ops4j.pax.exam.junit.JUnit4TestRunner.run(
> JUnit4TestRunner.java:94)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.execute(
> JUnit4Provider.java:283)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.executeWithRerun(
> JUnit4Provider.java:173)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.
> executeTestSet(JUnit4Provider.java:153)
> >
> > at
> > org.apache.maven.surefire.junit4.JUnit4Provider.invoke(
> JUnit4Provider.java:128)
> >
> > at
> > org.apache.maven.surefire.booter.ForkedBooter.
> invokeProviderInSameClassLoader(ForkedBooter.java:203)
> >
> > at
> > org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(
> ForkedBooter.java:155)
> >
> > at org.apache.maven.surefire.booter.ForkedBooter.main(
> ForkedBooter.java:103)
> >
> >
> >
> > On Sat, Oct 22, 2016 at 2:56 PM, Carsten Ziegeler <cziegeler@apache.org>
> > wrote:
> >>
> >> The main changelogs are in jira and at:
> >>
> > https://svn.apache.org/repos/asf/felix/releases/org.apache.
> felix.configadmin-1.8.12/changelog.txt
> >>
> >> Staging repositories:
> >> https://repository.apache.org/content/repositories/orgapachefelix-1150/
> >>
> >> You can use this UNIX script to download the release and verify the
> >> signatures:
> >> http://svn.apache.org/repos/asf/felix/trunk/check_staged_release.sh
> >>
> >> Usage:
> >> sh check_staged_release.sh 1150 /tmp/felix-staging
> >>
> >> Please vote to approve this release:
> >>
> >> [ ] +1 Approve the release
> >> [ ] -1 Veto the release (please provide specific comments)
> >>
> >> Thanks
> >> Carsten
> >> --
> >> Carsten Ziegeler
> >> Adobe Research Switzerland
> >> cziegeler@apache.org
> >
> >
> >
> >
> > --
> > Karl Pauls
> > karlpauls@gmail.com
> > http://twitter.com/karlpauls
> > http://www.linkedin.com/in/karlpauls
> > https://profiles.google.com/karlpauls
> >
>
>
>
>
> --
> Carsten Ziegeler
> Adobe Research Switzerland
> cziegeler@apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message